Closed Solved

GTX 460 SLI flickering RED overlay in some games

HI,

I am running a i7 930 with SLI GTX 460, problem is I am getting a flickering red overlay in some games with SLI enabled and yet not when SLI is disabled.

THe system works perfectly overclocked or not with SLI enabled on most of my games, GTA4, Civ 5, Metro 2033, Bioshock 2 etc etc.

However two titles only, when SLI is turned on exhibit this flickering red overlay on the screen, that is, Call of Duty Back ops and Star wars the force unleashed 2. The games were playable, everything worked fine, just this overlay colour, obviously I didnt go to far into the games with this issue.

Does anyone know why this might be happening? I recently updated the drivers to the newest, COD flickered with the newest drivers, while SWTFUL2 flickered on the previous version.

I tried turning the SLI bridge around the other way, but then the other cards not recongnised so I assume that its on the correct way around.
Also nothing is overclocked while the flickering occurs.
In the Nvidia 3d settings I have everything possible on application controlled.

Any thoughts?
11 answers Last reply Best Answer
More about flickering overlay games
  1. Best answer
    It might be a bad bridge, I don't know if they've changed things recently but it doesn't matter which way round the bridge sits on my cards.
  2. dava04 said:
    HI,

    I am running a i7 930 with SLI GTX 460, problem is I am getting a flickering red overlay in some games with SLI enabled and yet not when SLI is disabled.

    THe system works perfectly overclocked or not with SLI enabled on most of my games, GTA4, Civ 5, Metro 2033, Bioshock 2 etc etc.

    However two titles only, when SLI is turned on exhibit this flickering red overlay on the screen, that is, Call of Duty Back ops and Star wars the force unleashed 2. The games were playable, everything worked fine, just this overlay colour, obviously I didnt go to far into the games with this issue.

    Does anyone know why this might be happening? I recently updated the drivers to the newest, COD flickered with the newest drivers, while SWTFUL2 flickered on the previous version.

    I tried turning the SLI bridge around the other way, but then the other cards not recongnised so I assume that its on the correct way around.
    Also nothing is overclocked while the flickering occurs.
    In the Nvidia 3d settings I have everything possible on application controlled.

    Any thoughts?
    I second mousemonkey's response, I've had similar issues several times, always caused by either a bad bridge or a poor connection between the bridge and the card.
  3. Disappointing, I will look in to getting a new bridge.

    However, how would that explain the fact that it only affects two games out of the 10 I have played with this set up?

    Also would that mean that if the bridge were to be removed the red flickering should go away, suffering a lack of performance but proving the theory??
  4. dava04 said:
    Disappointing, I will look in to getting a new bridge.

    However, how would that explain the fact that it only affects two games out of the 10 I have played with this set up?

    Also would that mean that if the bridge were to be removed the red flickering should go away, suffering a lack of performance but proving the theory??
    If you remove the bridge you break SLI, and you said you don't have the problem without SLI. You could check the other card by swapping them and leaving SLI disabled, however.
  5. I know this is old now, but need to add something here. I had to take my video cards out for some reason or another recently, i put them back in and proceeded to play a game, flicker red screen again.

    I scratch my head and think huuummm bridge cant be broken it only worked yesterday and has been in a safe box the whole time. I turned the bridge around and the red flickering stops. SLI certainly on and working FPS confirms that in the game.

    I know many say that the bridge is not omidirectional, but this is my experience it might help someone.
  6. Did you get a new bridge?
  7. I did get a new bridge, back when you said to get a new bridge, and that solved the problem.
    My old bridge was certainly broken, actually when I examined it the wire was actually broken at the connection haha.

    The above is referring to while still using the new bridge I got on your advice.
  8. I'm happy to hear that the original suggestion was correct but now I'm wondering about the health of your cards because since this thread was started I have replaced my 8800GT's with GTX560's and even in new motherboard that they reside in the SLi bridge is still omnidirectional in that it works either way round.
  9. I hear what you are saying. THe SLI bridge works for most games in either direction, just some didnt, Metro 2033 for instance.

    It certainly is odd... I will give you that my cards seem fine enough as long as they are cool enough, although this latest nividia driver 280 seems to not like Areo being on!!!
  10. Best answer selected by dava04.
  11. This topic has been closed by Mousemonkey
Ask a new question

Read More

Graphics Cards Gtx Games SLI Graphics