Sign in with
Sign up | Sign in
Your question
Closed

Hd 4870 and still lag in black ops

Last response: in Graphics & Displays
Share
November 20, 2010 7:27:52 PM

hey
well i don't understand why its lag i run at 1280x1024 resolution and i have hd4870


my other things are

amd 7750 black
2x2g ram
320 hdd
770ud3 gega byte
500 watt ocz power

so any body can help me here because i just closed the game and i don't wanna play it like that

thanks in advace

More about : 4870 lag black ops

a b U Graphics card
November 20, 2010 7:44:24 PM

Black Ops is cpu bound, it needs a faster cpu. http://arstechnica.com/gaming/reviews/2010/11/call-of-d...
Both mhz and quad cores.
http://www.techspot.com/review/336-cod-black-ops-perfor...
Quote:
While testing different processors with Call of Duty: Black Ops, it became apparent that quad-core processors offered considerably better performance. Before we show you the results, here’s a quick CPU utilization screenshot.


Quote:
Call of Duty: Black Ops can take advantage of four cores and is undoubtedly optimized for the current crop of chips. In fact, the game relies so heavily on all four cores that we found it almost unplayable (OK, that may be exaggerating a bit) on even the fastest dual-core CPU. That said, AMD's triple-core Athlon II and Phenom II processors did provide lag free performance


edit:
Looking at the cpu support list for that board, you have plenty of options to upgrade.
I would pop in a PHII 955 or whatever you can afford.
http://us.test.giga-byte.com/Support/Motherboard/CPUSup...
November 20, 2010 8:39:26 PM

so i have to buy new cpu to play these game right ?
for me buying new cpu over 100 bucks to just play these game its not seem right

any other help here i would be apprciated
Related resources
Can't find your answer ? Ask !
a c 91 U Graphics card
November 20, 2010 8:50:25 PM

4870/512 or 1gig ? You can try lowering the in game settings. Did you open the CCC and check to see if the "let application decide" boxes are checked ? When ATI drivers are updated they reset to awful high settings sometimes. I would look carefully.
a b U Graphics card
November 20, 2010 8:54:45 PM

Folks in another thread are talking about Black Ops having a bug that causes CPU usage to 80-100% no matter what. And also saying that the game just plain performs poorly.

I can't vouch for this though because I refused to buy the game. :) 
a c 91 U Graphics card
November 20, 2010 9:00:15 PM

That's true but a patch was put out for that. Should have auto updated when he hooked to steam. If it didn't I'd google for the patch.
November 21, 2010 12:44:11 AM

swifty_morgan said:
4870/512 or 1gig ? You can try lowering the in game settings. Did you open the CCC and check to see if the "let application decide" boxes are checked ? When ATI drivers are updated they reset to awful high settings sometimes. I would look carefully.


what let application decide" boxes ???

and yes mine is 1 g hd 4870


Quote:
Folks in another thread are talking about Black Ops having a bug that causes CPU usage to 80-100% no matter what. And also saying that the game just plain performs poorly.

I can't vouch for this though because I refused to buy the game. :) 


if the game work in good statue it would be good but at these time no

Quote:
That's true but a patch was put out for that. Should have auto updated when he hooked to steam. If it didn't I'd google for the patch.


well the game require steam to run it so sure i did install it and updated it but still lag












thanks every one for replay so any other thoughts
a b U Graphics card
November 21, 2010 1:06:01 AM

What kind of performance did you get in MW2 ?
Its hard to say exactly , but some are reporting as much as 50% less fps in this game or more.
The game also likes Nvidia gpu's much more, notice the gts 450, beating the ati 4890 ?


November 21, 2010 1:09:47 AM

Hi there, i have the same CPU as you (7750 @2.8) with an ATI 5770 1GB and experience no lag with CoD Black Ops set to maximum. Some explosions stutter, but nothing very noticable, especially in online. Im wondering if you are experiencing lag on your internet connection? Or does this apply to both single and multi player modes?
a c 91 U Graphics card
November 21, 2010 10:56:49 AM

2263035,7,658453 said:
what let application decide" boxes ???

and yes mine is 1 g hd 4870


Open the CCC ( catalyst control center ). Click on graphics/3D. Go over to "all". Select "Use application settings" boxes. Disable A.I..... leave that one UN-checked. Performance set to
"quality". Wait for vertical refresh.... set to Off, unless application specifies. A-A Mode/Quality.. Hit apply.

Then go into the game and see how it plays. If it still acts a little funny make adjustments in the GAMES control panel.
November 21, 2010 12:44:24 PM

Spartanrevenge said:
Hi there, i have the same CPU as you (7750 @2.8) with an ATI 5770 1GB and experience no lag with CoD Black Ops set to maximum. Some explosions stutter, but nothing very noticable, especially in online. Im wondering if you are experiencing lag on your internet connection? Or does this apply to both single and multi player modes?



yes i have lag in multi and also single i can't play it like that but mine read 2.7 how come yours read 2.8 ?


mw2 was playing it like charm noooooo lag at all but these is too much lag
November 21, 2010 12:52:45 PM

swifty_morgan said:
2263035,7,658453 said:
what let application decide" boxes ???

and yes mine is 1 g hd 4870


Open the CCC ( catalyst control center ). Click on graphics/3D. Go over to "all". Select "Use application settings" boxes. Disable A.I..... leave that one UN-checked. Performance set to
"quality". Wait for vertical refresh.... set to Off, unless application specifies. A-A Mode/Quality.. Hit apply.

Then go into the game and see how it plays. If it still acts a little funny make adjustments in the GAMES control panel.
said:



here is how it look when i play and laggg even if i did defaulte sitting its lag






my sitting in cccc
smooth vesion ...........checked .............box

antisotropice filter ................unchecked ............4x

AI...............checked

mipmap...................................qulity


wait for vertical ............ off unless

anti aliasing .........checked............quality
a c 91 U Graphics card
November 21, 2010 1:31:48 PM


CCC:

AI.......... UNcheck.

antistropic.......CHECK ....... let application decide


GAME CONTROL PANEL.......... is there an auto detect ? If so try it.


corpses.... low or none

AA.... no

shadows..... no

full screen..... yes


75Hz normal for your monitor ?

a c 91 U Graphics card
November 21, 2010 1:41:22 PM

Check your virtual ram. And how full is your hard drive and is it defragged. And is this the only game you have problems with ?
November 21, 2010 2:00:07 PM

my hard drive not full at all i'm using 320 hdd in the partition c u can see there is 30 giga byte free out of 60 giga

and i just formated my windows and installed clean new one

for now yes these is the only game i play no other games are installed

and 75 refresh rate my monitor can handle it it did with mw2

i play all other games on 75 refresh rate and noo problem and no its not native the normal for my monitor is 60 hz i guess

and i did the sitting u said on ccc and its worest now lag is huge
November 21, 2010 2:54:48 PM

From the looks of that task manager screen shot, it looks like the cpu is causing your problem. If you could grab a similar screen shot but for the graphics card activity it would help. Also, make sure your ATI drivers are up to date.
November 21, 2010 3:39:35 PM

Spartanrevenge said:
From the looks of that task manager screen shot, it looks like the cpu is causing your problem. If you could grab a similar screen shot but for the graphics card activity it would help. Also, make sure your ATI drivers are up to date.



ok here is picture to show the gpu activity while i'm playing but i don't know if its real usage because when i puse the game and click on the ccc its show the activity from 60 to 77 but when i go back and resume it says 40 to 52




i have 1mb internet connection so its enough for online gaming right ?
November 21, 2010 10:32:39 PM

i Have a AMD 7850 oc to 3.35ghz and have a asus 512mb 4850. I also have the same issue. i have try to change the config. setting in the black ops files. still same issue. have the steam update and no different. online and campaign modes laggy very bad. I came to a conclussion to update the pc since it has been while. I looking at the PII x4 955 and a 6xxx series gpu. I have a fourm open to run a x2 4850 or upgrade to 5xxx or 6xxx series gpu.


Asus m3a78-t
X2 7850 oc 3.35
1066 4gb gskill oc
nine hundred case
November 21, 2010 10:38:57 PM

green gaint said:
i Have a AMD 7850 oc to 3.35ghz and have a asus 512mb 4850. I also have the same issue. i have try to change the config. setting in the black ops files. still same issue. have the steam update and no different. online and campaign modes laggy very bad. I came to a conclussion to update the pc since it has been while. I looking at the PII x4 955 and a 6xxx series gpu. I have a fourm open to run a x2 4850 or upgrade to 5xxx or 6xxx series gpu.


Asus m3a78-t
X2 7850 oc 3.35
1066 4gb gskill oc
nine hundred case


i will get the amd phenom 955 tomorrow and i will update here to let u know what happend

well i guess u card will do fine if u just mix the sitting and i don't know what resolution u use
but if its like mine it should'nt be problem to run the game mix out

i know the laggy part in multi and also single its soo annoying even when i play zombie lol
i also updated from steam but nothing happend
now i wish i had xbox360 but i just used to computer games more than any console espcially when it comes to first shooter games i like it to be in pc
November 21, 2010 10:46:36 PM

I was pulling 60fps on mw2 with highest settings. I also had no problems with mw2 i guess it time to upgrade look like the only way right?


any other input would be helpful.

November 21, 2010 10:52:52 PM

me too mw2 was just work great i don't know what they did do to final cod
soem say the engine of the game is similar to mw2 but i guess thats not true since the game need higher requirment or the devolopers just got the things messy or bad encoding well i don't not but i hate the game at these statue now and i wish that just to stop lag
alot of i7 owner and i5 have problem with the game
and also alot of ati gpu owner have problem with the game

my point is i guess the game seems to run perfect with amd cpu and nvidia cards
thats after i read comment from people around the web
a c 91 U Graphics card
November 21, 2010 10:54:07 PM

I google requirements and came up with this.... does it say tri core there ? You should try yougamers. Up top they have a "will my computer play this" thing. See what it says about yours. I never go by what's released by the game company's because they are in la-la land half the time. You should do a good malware scan of your system.

• OS: Windows XP, Vista, 7
• CPU: Core 2 Duo E6600 or AMD Phenom X3 8750 or better
• RAM: 2GB
• HDD: 12GB of free space
• VIDEO: Shader 3.0 or better; 256MB NVIDIA GeForce 8600GT DirectX 9.0c or better
• SOUND: DirectX 9.0c-compatible
• DirectX: 9.0c
a b U Graphics card
November 21, 2010 11:10:43 PM


That is a lot of cpu use, from a i7 920.
Quote:
Although it is a CPU bound game, Black Ops doesn't rely on a processor's L3 cache to perform at its best. The quad-core Athlon II processor X4 645 was just 6fps slower than the hexa-core Phenom II X6. Moreover, six cores are a waste in this game and the Phenom II X4 970 proved that added frequency is more valuable.

Something that’s immediately apparent when looking at the above graph is the fact that the Core i5 and i7 processors are far superior to anything else we tested. For example, when paired with the Radeon HD 5970, the Core i5 750 was a staggering 29% faster than the Phenom II X4 970, which we might add is clocked 32% more aggressively.

The Core i3 540 on the other hand crashed and burned, with just 42fps on average, making it surprisingly slower than the Core 2 Duo E8500. Clearly, Hyper-Threading technology was of little help here.


http://arstechnica.com/gaming/news/2010/11/call-of-duty...
After patch thoughts/comments
a c 91 U Graphics card
November 21, 2010 11:53:27 PM

As we speak......... 11-20-10.......... there has been put out a new patch. Launch steam and see if it updates and see if it helps..... ????
November 22, 2010 12:10:27 AM

well i have the latest patch and the game is lag much
so do i need to upgrade the cpu or just wait for new patch or ...............
November 22, 2010 1:54:28 AM

I dont think patches are going to fix this problem. This game has been design to run on 3 or higher cores and nivida gpu. there are no ATI specs on the requirements. I wish i can just play the game. Every time there a new game out that means PC upgrades and more money. just the nature of the hobbie. I will getting the 955 core any input on the 955 is it a good oc?

Best solution

November 22, 2010 2:38:23 AM
Share

you cannot expect to just magically summon up performance. you're going to need a new cpu if you wanna play well. Grab a phII 955/965 if you can, and it's not going to be just for black ops. A new cpu will boost overall performance in just about everything.
November 22, 2010 3:46:13 AM

What do u think about the EAH5850 Having good luck with it. also any input on the pII 695 black. stock is 3.5 good oc to 3.8 What case are u running to keep it cool
November 22, 2010 11:29:08 AM

i guess there no much differance between 955 and 965 the only thing i guess is the stock speed .955 =3.2 and 965 =3.4
November 22, 2010 1:31:28 PM

green gaint said:
What do u think about the EAH5850 Having good luck with it. also any input on the pII 695 black. stock is 3.5 good oc to 3.8 What case are u running to keep it cool

Hey, the eah5850 plays the game perfectly... after the patch, there is no lag whatsoever for the most part it plays capped at 91 fps. As for the PhenomII, the 965 obviously has a higher clock speed, but if you think you can oc the 955 to 3.8 then you'll be set when it comes to pretty much everything you can throw at it... one thing though... If you wanna OC the Phenom, you're gonna need to get an aftermarket heatsink, 'cause the one they give you is measly to say the least. Grab a Cooler Master Hyper 212 Plus. Make sure it's the plus and not the regular one, the regular one is missing the middle for some reason :o  Good luck!
November 22, 2010 2:12:00 PM

@martin71

so both 955 and 965 can oc to 3.8 with no problems ?
November 22, 2010 5:10:48 PM

no guarantees, every cpu is a tiny bit different, but you could very probably get it up to 3.8... I can get up to 4ghz relatively easily... but you WILL need an aftermarket. at 3.4 ghz with stock cooler I hit 56c max. Now at 3.8 ghz I hit 43 max.
November 22, 2010 11:34:49 PM

update : well i got amd 955 x4 today and its seems it fixed the issue i had with lag
first when i run the cpu the game was still lag alittle but after half hour the game worked perfectly at high max sitting with 75 fps well i guess the game need x3 or x4 cors when it comes to amd
well thanks every body for helping i guess i will need cooler for these so i can over clock it with no problems.... any idea? i never tried over clock before but it always nice to try it i guess
November 23, 2010 2:48:59 AM

notty22 said:
Download and install AMD over drive.
It will let you familarize yourself with all the options ,its cool looking an interesting.
Its part of the AMD experience. http://game.amd.com/es-es/drivers_overdrive.aspx
They also have a overclocking document. http://game.amd.com/es-es/content/pdf/AMD_Dragon_AM3_AM...
Unleash the Dragon :) 
http://game.amd.com/es-es/content/images/unlock/overdrive/CLOCK_ADVANCED.png
http://game.amd.com/es-es/content/images/unlock/overdrive/AUTOCLK.png

Very interesting... trying this out now :) 
November 29, 2010 1:22:56 AM

On Texture filtering go to bilear instead of trilear. It made a huge
difference in mine and I don't see any difference in the graphics.
Still looks great
December 10, 2010 3:49:20 PM

hey i posted upon a similar issue... im using phenom x2 550 with HD 4770...
The problem was surprisingly cured by turning OFF cool n quiet in my BIOS
a c 91 U Graphics card
December 19, 2010 8:03:28 PM

So, did you change the refresh rate to 60Hz like it should be for your monitor ? Are you still having problems ?
December 20, 2010 10:47:05 PM

Best answer selected by sky12.
a c 169 U Graphics card
December 21, 2010 6:29:21 AM

This topic has been closed by Maziar
!