Sign in with
Sign up | Sign in
Your question

Black screen- ASUS EAH4870 DK/HTDI/1GD5

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
November 24, 2010 1:28:28 AM

Hi there

I'm hoping that someonce can give me at least an idea of what might be the problem I'm having with the limited info that I have. I have a EAH4870 DK/HTDI/1GD5 videocard


Intel Core 2 Duo E7600 3.06 GHZ

Antec 650 Power

initially the MB led light would go on but nothing else would boot up, no fans nothing. I thought it might be a pSU issue but a friend tested a new power supply and thats not the issue. Everything DOES power up when the onboard video is disconnected. However there are 3 red lights flashing on the video card when this is doen and although the fans are working and it seems to have power I have a black screen,,

D1601 - Red LED On, shows critical temperature fault
D1602 - Red LED On, shows External power connector A was removed
D1603 - Red LED On, shows External power connector B was removed
D601 - Red LED On, shows critical Core power fault(THIS IS THE ONLY LIGHT THAT IS NOT LIT)
Any ideas?
a b U Graphics card
November 24, 2010 2:07:00 AM

did you connect both power connections on the video card?
m
0
l
Anonymous
a b U Graphics card
November 24, 2010 2:23:31 AM

Yes, both were plugged in
m
0
l
Related resources
a b U Graphics card
November 24, 2010 5:00:24 AM

What MOBO do you have?

Do the LEDs stay on?
m
0
l
Anonymous
a b U Graphics card
November 24, 2010 10:53:15 AM

Its a micro ATX IG41. The MB Led remains on at all times
m
0
l
a b U Graphics card
November 24, 2010 2:04:46 PM

Have you tried changing the BIOS setting under Chipset area, Intergrated Graphic Adapter.

See if it helps to change the setting from [IGD] to [PEG/IGD]
m
0
l
December 10, 2010 9:05:26 AM

I have The same problem. just got it from ASUS RMA and now black screen and 3 red light blink once then nothing. have u find a fix to this???
m
0
l
!