Sign in with
Sign up | Sign in
Your question

Age of Empires 2

Last response: in Graphics & Displays
Share
November 27, 2010 2:15:45 PM

AoE 2 on loading gives an error message that the graphics card needs to be checked and Directx8 + needs to be installed. The graphices card is new with up to date drives from Matrox and I have Directx9+ loaded.
Other games (EA) work perfectly well - what's the problem please????????????

More about : age empires

a c 173 U Graphics card
November 27, 2010 2:30:19 PM

That is very strange, are you using a cd install or a pirate copy? I have played ae2 on a matrox mga 200. Are you using XP and is it updated?
November 27, 2010 3:05:12 PM

nforce4max said:
That is very strange, are you using a cd install or a pirate copy? I have played ae2 on a matrox mga 200. Are you using XP and is it updated?


Thanks for the quick responcse. AoE is a genuine CD bought brand new. I have a brand new P650 Matrox AGP. I run XP Pro. Everything (drivers, Directx, XP) has been updated - I have spent hours on this just to keep the kids happy but no joy.
Related resources
November 29, 2010 6:33:37 AM

drivers are up to date for the card
what do you mean is AoE patched up please?
January 28, 2011 12:10:43 PM

Have you got the latest updates for Age of Empires?
Also if you are running windows 7 with AoE2 there are a whole bunch of major issues, me and my friends spent hours trying to sort it to play a LAN.

What you need to do is edit a few registry files and modify some game files in notepad, if you google 'Age of Empires 2 Windows 7" there will be multiple guides on how to do so.

If you do not want to do this or this does not work, make sure Virtulasation is enabled on your motherboards BIOS and try to run the game in 'XP Mode'.

If this still does not work then i would consider setting up an XP Installation on another partition and using a Dual-Boot environment to play your favourite RTS.

I hope this was of help/the best answer, enjoy :) .
!