Major problem with 4870 1GB....

Been having problems with Dead Space and Lead and Gold recently....my temps do not go over ~80 when playing the games and I get things like this:

http://forums.leadandgold.com/showthread.php?tid=920

It looks like major artifacting, but it is the only games that do this even when I run BC2 and BO on max settings...I tried to fiddle with all the CCC settings, re-installed drivers, and all of the other obvious routes, but nothing worked. Is it the 4870 or something else? Lead and Gold worked when I had the beta installed and now it doesn't...I did move my components to a new case, but I made sure that everything is hooked up correctly more than once.
4 answers Last reply
More about major problem 4870
  1. Clean the card?
    Re-apply the thermal paste?
    Restore setting to default? Factory setting?
  2. Did all of that and nothing worked.
  3. Bump please.
  4. The last thing you want is try your card in different PC, if the same problem appears then i think your card is going bad...
Ask a new question

Read More

Graphics Cards Games Graphics