Sign in with
Sign up | Sign in
Your question

Wireless Keeps Disconnecting. Please Help!!

Last response: in Wireless Networking
Share
Anonymous
a b F Wireless
September 25, 2010 9:04:09 PM

I'm running Windows 7 on a Sager NP2098 notebook and consistently run into disconnects. I know it's not a router issue because my roommate's connection is perfectly fine even when mine gets dropped. I've exhausted most of the advice given for people with a similar situation on different forums, but nothing seems to remedy the situation.

One interesting thing to note is that if I disconnect, it takes a long time (I never measured) to reconnect. Sometimes, it won't reconnect at all and I have to disable my wireless adapter and re enable it in order to successfully connect to my wireless. On most, if not all, occasions it is much faster just to disable/enable the adapter instead of waiting.

My adapter is an Intel WiFi Link 5100 AGN. It takes me less than a second to connect to my internet.

Please help with whatever advice any of you can give.

More about : wireless disconnecting

Anonymous
a b F Wireless
September 25, 2010 9:26:35 PM

May still be the router if its wireless mode is set wrongly for your adapter -- or there is a minor incompatibility between your adapter's implementation of wireless n and the router's implementation of it. See if the problem goes if you switch the router's wireless mode to wireless g.
m
0
l
Anonymous
a b F Wireless
September 25, 2010 9:33:53 PM

Instead of my current 802.11b/g? I'll try it now.
m
0
l
Related resources
Anonymous
a b F Wireless
September 25, 2010 9:36:10 PM

Your wireless adapter will support wireless n.
m
0
l
Anonymous
a b F Wireless
September 25, 2010 9:42:22 PM

Oh, I see what you mean now. On my notebook, wireless n is currently enabled and the wireless mode is currently set to 802.11a/b/g. I switched over the router (if it makes any difference, it's a 3600HGV from AT&T U-verse) to 802.11g.

Will let you know if I still get disconnected.

EDIT: I still get disconnects.
m
0
l
September 28, 2010 8:18:07 PM

try to uninstall the wireless device completely. Take the device out of your laptop. Download the newest driver. Reinstall the device using the new driver.

if that doesn't work try to disable b and n mode and just use G
m
0
l
September 28, 2010 9:59:16 PM

I uninstalled and reinstalled twice. I updated the drivers 3 times before that.

I went into the network card's properties and disabled n-mode and switched to a G signal, but I'm still getting disconnects.
m
0
l
May 10, 2011 4:22:05 PM

Quote:
I'm running Windows 7 on a Sager NP2098 notebook and consistently run into disconnects. I know it's not a router issue because my roommate's connection is perfectly fine even when mine gets dropped. I've exhausted most of the advice given for people with a similar situation on different forums, but nothing seems to remedy the situation.

One interesting thing to note is that if I disconnect, it takes a long time (I never measured) to reconnect. Sometimes, it won't reconnect at all and I have to disable my wireless adapter and re enable it in order to successfully connect to my wireless. On most, if not all, occasions it is much faster just to disable/enable the adapter instead of waiting.

My adapter is an Intel WiFi Link 5100 AGN. It takes me less than a second to connect to my internet.

Please help with whatever advice any of you can give.


I've noticed over years that Intel has had very many problems with their devices starting back up in laptops after they go to sleep, I have a pretty good feeling that if you get disconnected and can't reconnect, this is it. Intel knows about this problem in their display adapters and wireless devices but does not correct it because they are problems that interfere with your personalized settings, which are usually faulty when default.

Read this to get an idea of what your experiencing and use common knowledge to apply this to your current adapter. --> http://www.intel.com/support/wireless/wlan/pro3945abg/s...

TO FIX THIS*

Verify that you have your wireless adapter set on Maximum performance in Power Management Advanced settings.

|Right click on the battery icon in your taskbar->Power Options->Change Plan Settings{For the selected plan}->Change Advanced Power Settings->Wireless Adapter Settings|

Next you will have to go to device manager and change the setting that allows override of the Power Management because someone who designed it wasn't thinking clearly...

You can type in the search box in the start menu for Device Manager or go to
|Control Panel->Hardware & Sound->Look for Device Manager, it could be under Devices & Printers as well depending on how you have your category view layout->Right Click your Intel Display Adapter and select properties->Go to the Power Management tab and uncheck "Allow the computer to turn of this device to save power" Then Click OK


Please comment back to verify if this worked for you. I just figured this out in my laptop after months of extensively googling the subject, and have yet to of had any disconnects in the past couple of days or so.
m
0
l
May 29, 2011 8:16:23 AM

i have the same problem on my sager, all my friends don't disconnect so i know it's not a router issue. after a certain period of time using the wireless, especially when i'm downloading something, the wireless will disconnect and i will need to turn on and off the wireless before it works again. think there is something wrong with this wireless card...
m
0
l
July 25, 2013 9:02:18 PM

i have the same problem when downloading something, my wireless disconnets and then reconnects 4 to 5 secs later.
m
0
l
!