Sign in with
Sign up | Sign in
Your question
Solved

DP43BF BIOS Update

Last response: in Motherboards
Share
January 5, 2012 11:56:07 AM

hello everyone! I recently put together my system with this DP43BF Intel Motherboard and I'm currently encountering issues with installing Windows for the reason that whenever the "Starting up Windows" part flashes, the BSoD comes up and tells me that "the bios in the system is not fully ACPI compliant" and that I should be updating the BIOS. Unfortunately, I have been trying to do this to no avail. I've tried following the instructions from the board's support page such as:

-using the F7 method to updating the bios and putting the *.bio file in a USB (results in what looks like just a reboot; the bios version is still the same when checked.)

-I tried making a USB boot disk, then type that IFLASH2 /PF XXX.BIO and I also get the same result (count down to a restart???)

-I tried using a CD with the bios file in it and taking out the jumper, as i've been told to do, and then power-up the system after doing so. I put the CD in, take out the jumper (poweroff first), power-up the system, and all i get is a black screen?? the instructions on the support page says to wait 5-10 mins and the system would either shut down or tell you to do so but after waiting for over an hour, the screen remains black. I held the power button frustrated and returned the jumper, then checked the bios afterwards and the system seemed fine but the bios version still remains the same.

Can someone assure me that updating the bios will finally allow me to install windows and get past BSoD? If so, I would LOVE anyone who could help/guide me through more methods to try to update the bios.

I've been at it for 3 days solving so many issues, researching everywhere and im so near yet so far!! I'm hoping some expert here would help me in getting this first-time build of mine to work. please help! i can't wait to get this done! I willl APPRECIATE any help i can get :)  Thanks in advance!

More about : dp43bf bios update

a c 717 V Motherboard
January 5, 2012 12:21:45 PM

Welcome to Tom's Forum! :) 

Use the 'RK0088P.BIO' file, you 'might' have placed the ZIP file on the Flash Drive.

Use Iflash BIOS Update or Express BIOS Update if the Flash fails, the Flash Drive MUST be formatted FAT-32, Bootable and the '.BIO' must be in the 'root' aka primary location (i.e. not in a file or partition).

Good How To video:
m
0
l
January 5, 2012 12:39:18 PM

thanks for the welcome jaquith! really appreciate it! :) 

I've already done what you told me though and what happens is that after i press enter, all that happens is it shows me this:

IFLASH ver. 2.4... something something

then the screen goes black going into a restart :(  could it be that my bootable USB was incorrectly made? i checked and it is formatted as FAT32. I used the instructions from this link to make the USB bootable:

http://www.biosflash.com/e/bios-boot-usb-stick.htm

what else could be the issue here? i hope the board isn't broke :/  :/ 
m
0
l
Related resources
a c 717 V Motherboard
January 5, 2012 12:46:51 PM

I'd try a different 'DOS' approach to the Flash Drive, from what you're saying the problem 'seems' to be originating there. Also, you need to change the BIOS Boot order to the Flash Drive being the primary boot device. Fortunately, there are several ways to flash.

I also assume that you are using the correct BIOS for your MOBO -> http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...(64-bit)*&DownloadType=BIOS

If that fails then Express BIOS Update:

m
0
l
January 5, 2012 1:07:55 PM

ohhh i see! so what i should try is find another DOS image (not sure if thats a correct term to use haha) to use for the USB and see if it would work yea? would you know any good links to where i can find a better DOS approach like you said? I've been searching for days. maybe you'd have a personal favorite that you use if that would be okay? :) 

and oh, yes i did download that same file onto my USB

*EDIT: oh and i also put the boot priority to the USB too

regarding the express bios update however, I can't do that method w/o getting into windows am I right? or can I? cos I can't seem to install windows without running into the BSoD, telling me to update the bios first (Hopefully I'll be able to install windows after doing so)
m
0
l
a c 717 V Motherboard
January 5, 2012 1:39:31 PM

Above the 'Bootable' is indeed a link -> http://www.sevenforums.com/tutorials/46707-ms-dos-boota...

Yep and correct, the Express BIOS Update requires you to boot into Windows. Obviously, if you cannot boot into Windows that approach won't work.

Another alternative is the F7 BIOS Flash as you mentioned:

m
0
l
January 5, 2012 2:14:22 PM

Thanks so much for the help and alternatives jaquith! i tried the one in your link but unfortunately, it still goes immediately to a restart after pressing enter :(  same goes with the F7; it just counts down to a restart. is this normal? :/  I really hope there are more solutions.

Im not sure if i successfully did the recovery method that was listed in the support page. The one where I had to remove that so-called jumper. I just burned the .BIO file onto the CD i then inserted then powered up after removing the jumper. is that the right way to do it? cos all i got was a black screen on power-up.
m
0
l
a c 717 V Motherboard
January 5, 2012 2:24:52 PM

I assume that the Flash Drive is ONLY connected to the REAR I/O and not off some other USB port. The Jumper MUST be in it's DEFAULT position and NOT in it's 'Clear CMOS' position.
m
0
l
January 5, 2012 2:29:13 PM

i tried the rear and the front; same result for both :(  hmmmm.. any other ideas?
m
0
l

Best solution

a c 717 V Motherboard
January 5, 2012 2:37:35 PM

Again, the following:
1. Rear I/O USB Port only
2. Jumper Default position

Another reference link -> http://www.intel.com/support/motherboards/desktop/sb/CS...

Jumper -> http://www.intel.com/support/motherboards/desktop/sb/CS...
Note the recovery with NO Jumpers; might be worth trying.
Share
January 5, 2012 10:10:15 PM

I LOVE YOU MAN! HAHA I removed the jumper then put the BIOS on the USB, power-up the computer and the FINALLY, the flash update proceeded! thanks jaquith! i'll definitely come back here and let you know if Windows installs and if i encounter more issues! :) 
m
0
l
a c 717 V Motherboard
January 5, 2012 10:30:09 PM

Glad to hear!!! :sol: 
m
0
l
January 5, 2012 10:35:25 PM

Best answer selected by miggycon.
m
0
l
January 5, 2012 10:37:40 PM

UPDATE: Windows is finally installing! thanks A BUNCH again jaquith! I suppose this problem is SOLVED :) 
m
0
l
!