Sign in with
Sign up | Sign in
Your question

4870x2 issues PLEASE HELP

Last response: in Graphics & Displays
Share
December 4, 2010 11:00:22 AM

Hi,
I'm having serious issues with my 4870x2. I went to the new 10.11 drivers and when I go to play any game I get extremely jacked up graphical gliches. There is no tearing or anything that looks like its due to over clocking (because its not over clocked) but I just get weird stuff. Specifically, I boot up Napoleon Total War and go to play a battle and it takes 2+ minutes to load and when it finally does I have a picture of an ocean washed over land terrain and everything else is invisible. I go to CCC and choose to have the application control the 3D settings. That fixes the terrain problem but now any game I play runs extremely terrible- like I have $10 gpu. I reverted back to previous drivers and even tried 10.5 version of the drivers for my card and I still have the same problem. I've never had this happen before and I feel like I've tried everything. I'm ready to throw my computer away.



ATI Raedeon 4870x2
8 Gb Kingston HyperX RAM
Intel Core 2 Duo over clocked to 3.50 GHz
60 Gb Western Digital HDD 7200 RPM
1000 W thermaltake PSU

I should have no problems running anything on max settings with no loss to FPS. I never have before. Has anyone else had problems with this card or is it all ATI cards that suck? I have had a graphical problem/ glitch for every game I've ever played that isn't 4 years old.

PLEASE HELP ME

More about : 4870x2 issues

December 4, 2010 1:22:18 PM

Have you tired remving the drivers using a driver sweeper before reinstalling?

m
0
l
December 4, 2010 1:47:35 PM

no I've never heard of driver sweeper. I uninstalled the ATI Installer and did a file search for anything related to ATI and deleted them. I even deleted the gpu from device manager and started over with the new 10.11 update.
m
0
l
Related resources
December 4, 2010 2:02:33 PM

Well it would be best to run it to make sure all of the driver entries are removed just to make sure. As your troubles started after the driver update it should right it by removing it completely.

I am still on 10.10 so not sure if this is an isolated incident.
m
0
l
December 4, 2010 2:47:20 PM

Problem solved. Thanks a lot. Driver sweeper is a life saver, I was about to toss my ATI card today if I couldnt get it working. Although, when playing some graphically intensive games I have to turn off SSAO and tone down AA and Antriscopic Filtering a tad in order to get decent fps- even though my pc can fully handle these games. Do you know what could cause this?
m
0
l
December 4, 2010 4:13:15 PM

Not sure, is crossfire working ok?

Which games is it that you are having problems with.
m
0
l
December 4, 2010 5:13:27 PM

Asus Ve228hgames when my pc is morethan capable.
m
0
l
December 4, 2010 5:17:21 PM

Sorry for the typo above I'm on my iPhone. I just have framerate problems and some flickering in empire total war and Napoleon total war. The sims 3 has green boxes all over the place when anti aliasing is on. I have other games but they're really old and run fine. I just hate having these problems when my pc is more than capable to run it with no problems.


As far as I know I don't have any control over cross fire with the 4870x2. If I do I haven't ever found an option for it in ccc
m
0
l
December 4, 2010 5:58:27 PM

It is the catalyst A.I.

If you disable it, it disables crossfire. Also disables game specific optimisations as far as I know but it can be useful for certain games.

m
0
l
December 4, 2010 6:35:13 PM

Where's the option for disabling it? I've looked all over and I don't see anything about crossfire anywhere. What are the advantages and disadvantages to disabling it?
m
0
l
December 4, 2010 7:26:30 PM

It doesn't actually mention crossfire specifically, the catalyst A.I controls it however. I find for one or two of my games notably Mount and Blade that crossfire can cause flickering for some reason. Most games run fine but some do not and need to run on a single gpu.

The catalyst A.I is under the 3-d settings in the CCC.
m
0
l
December 4, 2010 7:29:23 PM

Thanks for all your help I'm goin to go check this out now.
m
0
l
!