Sign in with
Sign up | Sign in
Your question

Sabertooth X79 can't install windows

Last response: in Motherboards
Share
January 7, 2012 11:30:28 PM

So here's the deal, I just got an x79 board, trying to install windows on an ssd drive, I already found out the hard way about launching the install disc as uefi and gpt being automatically chosen for that. I also learned that instead of putting the boot drive at the top of boot priorities you need to put windows boot manager first. I know all my hardware is good from tests and i'm running at stock bios 0906 so rule that out.

I still, after installing windows and restarting for the first time, get the boot manager screen saying windows couldn't be started and telling me to restart with a repair disc or launch startup recovery. That's on the three times (out of about 30 so far) that it even restarts to finish installing (the point where you assign a username etc). The bios seems to enjoy changing the boot priority order halfway through my installations.

I'm currently on day 2 of trying to get this thing to boot into windows after the first install restart. I've never encountered this in 4 versions of windows, does anybody know what's happening?
February 26, 2012 8:08:36 AM

I exactly have the same problem. I could install win-7 64 on a SSD 3 weeks ago without any problem. I used the Intel RAID mode with 3 HDD's and the SSD (2 x 1TB sata 3GB with RAID 1 and 2 non-raid sata 6GB: the SSD and a 2TB to copy data on the RAID 1). Everything was just fine. Then I disconnected the 2TB. Since then, no way to boot Win-7, to recover/repair with the win-7 DVD and even to reinstall Win-7 with the DVD. Exactly the same problem as mentioned in your email. Very weird. I can boot with the WIN-7 install DVD, load the F6 driver and start the installation on a HDD (raid or not) or on the SSD (I tried with all). All hardwares are working fine (I checked on another PC). After installation, Win-7 starts to boot and then always quickly stops with the error code 0xc0000221 (on file CI.DLL).

The main difference I can see is in the BIOS: There is now a Window Boot Manager, which I did not see before. I tried to get rid of it: reset the NVRAM, even by taking out the lithium battery / short circuiting and then reloading the bios. Every bios parameter was cleared but not this Window Boot Manager.

This reminds me of the MBR problems I used to have in the late 80s. I though such problems were gone by now. Apparently, Intel, Microsoft and Asus just did not check all possible configurations with this new GPT/UEFI system. Hope they find a solution soon.

Did you find a solution to your problem? This could help me.

My system: Asus X79 Sabertooth / Intel 3930k / G.Skill 1866 16 GB
m
0
l
Related resources
a c 207 Ĉ ASUS
a c 717 V Motherboard
February 26, 2012 12:17:01 PM

Preperation:
* Backup data
* Create Bootable Flash Drive MBR FAT32 USB ; 2GB+ use GPT
* Nice guides -> http://www.overclock.net/t/1156654/seans-windows-7-inst...
* Download the Intel RST Enterprise drivers: F6 and Install sets (either works, Intel's are newer):
** ASUS: Latest Drivers including the F6 drivers for Intel RST - http://usa.asus.com/Motherboards/Intel_Socket_2011/SABE...
** Intel: Latest Drivers including the F6 drivers for Intel RST - http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...
* Create a folder on Flash Drive e.g. 'IntelRST' containing extracted 'F6' Intel RST drivers
* You must use a Native USB 2.0 port i.e. one controlled by Intel and not a third-party including USB 3.0.


FIX:
1. BIOS:
A. Ctrl + I -> Deleted RAID
B. Intel SATA -> RAID
C. Ctrl + I -> Setup RAID; before OS if boot drive

2. F8 - Boot from USB, select 'Install Windows', select Add drivers:
A. {ASUS site} Load RAID drive from 'IntelRST' folder; 'Flash Drive':IntelRST\RSTe_V3002003_XPWin7\RSTe_V3002003_XPWin 7\Driver\Disk\64bit\iaStorA.inf
A. {Intel site} Load RAID drive from 'IntelRST' folder;'Flash Drive':IntelRST\RSTE_3.0.0.3020_F6-Drivers\RSTe_3.0.0.3020_F6-Drivers\RSTe_f6_iaStorA_64\iaStorA.inf
C. Delete any partitions, and reformat
D. Install Windows
E. Install Intel RST Enterprise software
F. Boot into BIOS

3. BIOS:
A. Ctrl + I -> Setup RAID; if data drives

4. Windows:
A. Management, Disk Management -- add drives and format for non-boot RAID drives; don't mix MBR with GPT or visa versa

---

Footnote: IMO don't install off the Windows DVD and use a Flash Drive for the RAID drivers. First, I don't and didn't. Next, there have been reports that those who do/did upon removing the Flash drive Windows fails to boot but when the Flash Drive is inserted it boots = bad.
m
0
l
February 26, 2012 1:51:19 PM

Hello


I have had this exact issue for about 2 days now...

I already tested a lot of method and find one working for myself.


I tried the secure erase for the ssd, the clean all with disk part and so on...
The bios of the motherboard was also updated to 906 but when the mb arrived I had the 604 if I remember correctly so I told to my self what if it was bios related...

So my solution was to boot with the asus drivers CD, you will find an old version of the bios 0404 something like that and just flash your bios. Once you reboot, just load windows install, open a command (shift + F10) and make a clean with diskpart.

Once it's donc just go with the installation.

I will re-flash the mobo once I will have windows fully installed, if there is a problem I will thell it here otherwise it will be good.

Good luck !
m
0
l
a c 207 Ĉ ASUS
a c 717 V Motherboard
February 26, 2012 1:54:07 PM

Considering I'm running the latest BIOS and RAID on my X79 I know the my above post works. ;) 
m
0
l
September 11, 2012 1:29:00 AM

I ran into the same problem, but if in the installation window you click New, it will setup the disk so that you proceed with the install.

Problem is that the UEFI Bios system under which th ASUS x79 MB's work, you must have a GPT(EFI) formatted disc. If you use a previous HD(SS or mechanical) that has been setup initially in MBR mode, the UEFI BIOS will not read a bootable drive image on your disc, or allow you to install Windows without converting it to GPT. That's what is done automatically for you as described above, or you can manually switch it in Diskmanagement. PLease note that completely reformatting your HD does not change the basic conformation of your drive. You have to first format it, then right click on that drive in DiskManagement(not in the main pane but the most left hand column), and select convert to GPT. If you have a GPT disk, that menu item will be listed as convert to MBR, so the two are interconvertible and it just takes a second. Note that the HD must be unallocated before you can make the conversion, so you can't do this conversion and preserve the data on the disc; therefore back up first.

You can then format the converted disc, using new simple volume.

You now will be able to install Windows without any problem. You will note that unlike the MBR type installations where everything is in the same partition, under the UEFI(GPT) system there is a small 100 MB partition added which contains all the low level booting information, so it is absolutely essential in the booting process. Don't try to eliminate it, or your drive will not boot. There is also a very small additional, hidden partition, called MBR Protect, which prevents the installation from being potentially corrupted by attempts to alter non-existent MBR files.

I hope this helps you. By now, I expect you probably have already found a solution to your problem.
m
0
l
!