Sign in with
Sign up | Sign in
Your question
Closed

XFX 5770 Problem?

Last response: in Graphics & Displays
Share
December 7, 2010 3:52:22 AM

Hello, I'm hoping someone has experienced this issue and can help. I just built a new pc and so far so good except when gaming. What happens is when i play starcraft 2 or say operation flashpoint (1080p high settings) the games will play for 10-30 minutes (it varies) before it slows down to only a few frames per second. Another thing that happens is when i move the mouse the sounds starts skipping. I'm able to save just before the computer finally freezes and i have to hard reset. Note: if i stop movement of the mouse fps are normal? I called xfx and they said possibly memory but i'm not so sure, I ran the windows 7 memtest - no errors. I tried each dim individually - same problem. I've also tried re-installing drivers, checking bios to ensure dram setting were correct - they are. I pulled the graphics card and re-seated. I opened the case to test for heat issue, card never goes over 60c...I do not overclock anything.. I don't know what to do...


Specs:

amd phenom II 955 @stock 3.2ghz
asus m4a89gtdpro/usb3
xfx 5770 - revision 2 card (egg heatsink)
2 x 4gb corsair xms 1333mhz memory modules (in dual channel)
750 watt lsp
1 tb sata 6 g/bs western digital black hard drive

More about : xfx 5770 problem

Best solution

a b U Graphics card
December 7, 2010 5:28:25 AM
Share

I see, well you said your temps are about 60-thats fine no throttling down problem then, you reinstalled driver, i hope you removed them before and cleaned registry prior to reinstalling did you ?
Whats the full model name of your psu ?
December 7, 2010 5:55:23 AM

When installing the drivers I completely removed catalyst (selected all then unistalled. then went to control panel - device manager to make sure it was uninstalled. Restarted computer, window 7 64bit installed a default driver, i uninstalled that. then ran the catalyst driver program for the 5770, re-started. Device manager shows it to be working properly. I did not make any registry changes, or run a registry cleaner type program. Is that necessary? My power supply is...

Ultra LSP750 750-Watt Power Supply

Related resources
December 7, 2010 8:39:54 PM

Best answer selected by malibumike.
December 7, 2010 8:41:17 PM

I ran a registry cleaner called and that seemed to do the trick, play starcraft 2 for 2 hrs, no issues. Thanks!
a b U Graphics card
December 8, 2010 3:08:17 AM

Np Enjoy ;) 
a c 169 U Graphics card
December 8, 2010 6:28:52 AM

This topic has been closed by Maziar
!