Sign in with
Sign up | Sign in
Your question

Why will my os only boot when ide hdd disabled?

Last response: in Systems
Share
February 6, 2011 3:31:29 PM

hello everyone, i just want to start by saying thank you to everyone who posts here, i've been muddling my way through building and setting up a pc for the first time and got a lot of help from these pages.

i've finaly got my system up and running and aside from a pretty hot mobo temp (52 C) everything is in good working order. there is one small matter which has me really confused though...i set up xp on a sata hdd with raid disabled as initially was installing xp and didn't have the ability to pre-install the sata drivers. in this case the drive showed up in bios under third ide channel. my cd and dvd roms are under 2nd channel and now i've installed a ide hdd under the first channel and have it set as slave with jumper(don't think this matters when using sata and ide together but thought i'd set it to be sure). the issue is that when i set bios to recognize this ide hdd (i.e. to auto-detect) it shows up in bios and i set the hdd priority and boot priority to use the sata drive first with o/s on it and then it fails and gets stuck in a loop of booting but failing to load the o/s?

i then tried enabling raid just as a shot in the dark and that gets me as far as the "windows didn't start properly" screen but when i start windows normally it re boots? finally i disabled the auto detect for 1st ide channels so the ide hdd drive doesn't register in bios but low and behold the system starts and prompts me to update drivers for the new hardware at which point it located and installed sata raid drivers for xp. it boots and loads the os fine now and windows recognizes both hdd but i'm confused as to why the settings work in this way and i'm still not sure whether or not my sata HDD is working properly as a sata or still being used like ide? should i just be happy that all is working or am i sacrificing performance from my two hdd because i haven't configured bios properly? any and all help and suggestions will be greatly appreciated!

System Specs;

ASUS a8n32-sli deluxe mobo
AMI v.02.58 Bios 1303
WD500gb SATA HDD (Black Caviar)
WD200gb IDE HDD
nVIDIA SATA and SATA RAID Drivers are installed as well as up to date IDE controllers

thanks again,

ryan

More about : boot ide hdd disabled

February 8, 2011 2:55:05 AM

this issue was solved in another thread. problem: OS is on SATA drive and IDE must be first in boot priority meaning: removing the SATA and re-install windows on the IDE and removing it from the SATA drive.
m
0
l
!