Sign in with
Sign up | Sign in
Your question

Quadro NVS 420 / Dell Optiplex 760

Last response: in Graphics & Displays
Share
December 7, 2010 6:38:14 PM

Hi, I have a Dell Optiplex 760 desktop with Windows Vista 32. I recently purchased a Quadro NVS 420 graphics card so my desktop could support (4) monitors. Unfortunately, I cannot get the graphics card to work. I currently have a GEForce 200 series card. I think the problem may be the uninstall of my old graphics driver because the new Quadro card works on the other desktops in my office (which are identical to mine).

Can someone help?
December 8, 2010 11:34:46 AM

Quote:
the card should have at least powered on and gave you a display, did it.
in vista when you installed the card and booted windows should have detected the card and found/installed drivers for it.
no need to install drivers from a disk that came with card.
you might have a bad card (this particular one) try it in another unit..
to try and have this card working on your unit, if possible
then download nVidia clean sweep to remove all current drivers in your unit.
then when rebooting, just let windows install what it calls for.
try that and if it doesn't work then it's a bad card.
(or power supply but that's a reach, right now)


When I install the card, it powers on, but I get no display on my screens. I know the card works, as I've tried it on almost identical desktops in my office. I'll try downloading clean sweep, but does this sound like anything anyone has heard of before?
m
0
l
December 8, 2010 5:56:56 PM

Yes, I have tried this specific card in other machines, and it worked fine. The only difference between the other machines and mine is that mine currently has an aftermarket graphics card installed. I will try wiping the the existing graphics card via the BIOS and see how that works. However, I'm not too familiar with doing this.
m
0
l
Related resources
December 8, 2010 6:10:11 PM

Is your power supply equipped to handle the increase in power consumption?
m
0
l
December 8, 2010 6:20:04 PM

The card works on other IDENTICAL desktops in my office. So I am assuming this desktop it is adequately equipped
m
0
l
December 15, 2010 11:17:03 AM

The 760 is a regular desktop, not small form factor.
m
0
l
December 22, 2010 11:42:47 AM

Best answer selected by surferc22.
m
0
l
February 3, 2011 7:09:07 AM

surferc22 said:
Hi, I have a Dell Optiplex 760 desktop with Windows Vista 32. I recently purchased a Quadro NVS 420 graphics card so my desktop could support (4) monitors. Unfortunately, I cannot get the graphics card to work. I currently have a GEForce 200 series card. I think the problem may be the uninstall of my old graphics driver because the new Quadro card works on the other desktops in my office (which are identical to mine).

Can someone help?




hi,

i have same problem, i just wondering did you fix it, if yes, how did you fix it??

thanks
m
0
l
October 19, 2012 4:15:01 PM

Installing these in to some Lenovo's, I had to go in to BIOS and change the video from Auto detect to PCIe. Before that, Windows wouldn't even recognise the card nor could I get video out through any port on the card.

Would also be handy if these shipped with small form factor face plates, I had to butcher mine in the workshop, couldn't wait the indefinite time to get the supplier to send these out.
m
0
l
!