Sign in with
Sign up | Sign in
Your question

Computer Shutting Down Under Load

Last response: in Components
Share
May 7, 2011 2:37:34 AM

I recently was running my computer on crysis 2 and was playing it just fine for like 2 days then all of a sudden on a mission I started smelling something like a circuit burning so I instantly shut the system down to prevent any damage that might have been caused. So I checked the board and every where but there was no damage that I could see. *Not removing the heatsink from my processor* and now every time I run any game like WOW,Portal 2, Crysis 2, NFS HP, I don't get more then 5min in if that before it shuts down. First the screen goes blank then the system clicks and just shuts down. I can run it regularly just fine but I just spent 100$ on a new psu to replace the one I thought fry'd and still the same problem. If anyone can help it would be much appreciated..

Thank you.

Pc Specs:
Raidmax Tornado Case
Ati radeon 4850 His IceQ 1gig
AMD athlon X2 Black Edition
Evercool Buffalo Heatsink
OCZ Fatal1ty Edition 4GB (2x2GB) 240-Pin DDR2 SDRAM DDR2 800
SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM SATA 3.0Gb/s
Foxconn A7DA-S AM2+/AM2 AMD 790GX
Antec Earthwatts 80+ certified 750 Watt power supply

More about : computer shutting load

a c 77 ) Power supply
May 7, 2011 3:45:41 AM

My guess is your PSU followed by your GPU.

If you have the capability to switch one or both items out, I would do so to test. With the burnt smell, it sounds likely it is a PSYU issues (card is strong enough for system just might have been bad.
m
0
l
!