Sign in with
Sign up | Sign in
Your question
Closed

Asus M4A87TD/USB3 -- Windows 7 boots while no Linux Distro Boots

Tags:
  • Asus
  • Windows 7
  • Linux
  • Motherboards
Last response: in Motherboards
Share
January 10, 2012 3:27:52 AM

[SOLVED]

I am running both Fedora 14 and Windows 7 Professional on a home-built machine. The two operating systems are installed on different internal hard disks, and boot using Grub v1.99. The motherboard is an Asus M4A87TD/USB3 equipped with an AMD Phenom II 1075T processor and 16GB of RAM (G.Skill running at 1333Mhz).

Since the beginning of December, Fedora 14 and all other distributions of Linux have been unable to boot. During the boot process, the Grub screen appears and allows me to select between the operating systems installed. When I attempt to boot Fedora 14, the Grub screen is replaced with a screen of kernel errors, which run until I shut off the machine. This happens with all other distributions of Linux I've tried, both as Live CDs and bootable USB sticks, regardless of whether the internal hard disks are connected to the motherboard.

All the while, the computer boots Windows 7 Professional without incident. I suspect that I may have allowed Windows 7 to update some kind of Asus motherboard driver or firmware, but I cannot find evidence of that in the "uninstall programs" control panel in Windows 7. Further, the Asus website does not appear to have any firmware update for the motherboard other than a BIOS update, which I have yet to perform.

Attempted solutions:

* Booting from a USB stick with the latest available Linux kernel
* Uninstalling all Windows 7 updates back to October 2011 (long before the problem started)

Solutions I'm thinking about trying:

* Updating the BIOS
* Replacing the motherboard

My questions to the community:

* Have you noticed such behavior in Linux-Windows machines before?
* Under what circumstances have you noticed this similar behavior?
* What do you think might be the cause of my problem?
* What solutions would you recommend I try?

Thanks, all.

More about : asus m4a87td usb3 windows boots linux distro boots

January 10, 2012 4:23:36 AM

This has happened to me before while trying to run Ubuntu on a separate harddrive and I have the Asus M4A89GTD/ USB 3 pro. I had Ubuntu installed inside Windows and after a few weeks or months of not using Ubuntu, I decided to try and boot it up and I got a black screen feeding much errors.

I think the problem might have to be with something inside windows. I would probably try to look for some stuff on Ubuntu or some other Linux forums.
Score
0
January 10, 2012 3:46:00 PM

Thanks for the reply, pacmanandre. I'm sorry to hear you've had the same problem that I have, may I ask what solution you used? If it's too complicated to go into detail here, can you post a link to the procedure you used?

Thanks!
Score
0
Related resources
January 10, 2012 7:26:10 PM

I just uninstalled it in Windows from Control Panel and resintalled from scratch.
Score
0
January 10, 2012 7:30:33 PM

What software did you uninstall, exactly? I can't tell what software you're referencing. Do you mean you uninstalled Windows? Or Linux? Something else? Thanks, pacmanandre, I'd appreciate it.
Score
0
a c 207 Ĉ ASUS
a b $ Windows 7
a c 717 V Motherboard
January 10, 2012 7:37:57 PM

In your case of separate drives, and what I do (Windows 7 x64 Pro, RHEL, Ubuntu, and Mac OS X ; 4 drives) is to use 'BIOS Profiles' as a 'boot selector' as opposed to some other boot loader. Windows 7 doesn't play well with others, and I have separate BIOS environments with my OSes.
Score
0
January 10, 2012 7:50:28 PM

Thanks for the suggestion, jaquith. I'm looking into that as a policy going forward, but as I'm unable to boot Linux at the moment.
Score
0
a c 207 Ĉ ASUS
a b $ Windows 7
a c 717 V Motherboard
January 10, 2012 8:22:05 PM

The reason I suggest/do it this way -- House of Cards. Like you're experiencing now.

IMO - disconnect the other drives and run (Boot Repair) etc and then Windows F8 Startup Repair.
Score
0
January 17, 2012 3:41:13 AM

[SOLVED]

This issue has been resolved. It turns out that one of my RAM chips was defective. I became aware of this first by running "memtest," available in the GRUB menu on startup. When memtest revealed errors during RAM testing, I tested each chip individually, determining that one of the four was defective. After its removal, I was able to enter 64-bit Linux on the very next boot.
Score
0
!