Sabertooth 990FX Device Boot LED

Hi everyone, I've just built my first PC - components are in my signature - and when I power it up all the lights and fans work but there is no signal detected through the HDMI or DVI so I can't access the BIOS or see what's on the screen. The Device Boot LED on the board is lit and there are no beeps when the PC is turned on, please help!
36 answers Last reply
More about sabertooth 990fx device boot
  1. Case: NZXT Lexa S
    CPU: AMD FX-8120
    MOBO: Sabertooth 990fx
    PSU: XFX PRO850W
    GPU: XFX HD 5750
    RAM: Corsair 8GB 1600MHz
    HDD: WD20EARX
  2. recheck all cable connection
  3. Could it be as simple as that?
  4. could be just a cable not in place
  5. Ok well I can't check that right now but I will as soon as possible, thanks. What if that isn't the problem?
  6. will have to test card in another mobo or the monitor
  7. Are you sure your GPU is seated properly, and not at an angle? Is your power plugged into your GPU (if it has one)?

    Is your screen set to the proper setting - if your connecting through HDMI, is your screen set to display from the HDMI?

    Have you tried clearing the CMOS, and trying again?
  8. The monitors connections are fine, as are the wires being used.

    GPU is seated properly and the power cable is plugged in correctly.
    The screen is on the right setting as well and the CMOS has been cleared.

    Not sure what else to do :'( Ive heard of people booting it without the RAM or HDD installed but I don't see why that would work.
  9. did you check the post led as describe in manual page 2.20 if a error is found
  10. Yes but there were no beeps when I turn the system on
  11. what do you recommend now?
  12. as scout mentioned:

    "will have to test card in another mobo or the monitor"

    Try your GPU out in a different computer to see if your GPU is DOA. As well as try out your screen on a different computer that you know works.
  13. The screen works with everything, I dont have access to another computer to try my GPU in :(
  14. does the led on the board give you a error on post
  15. you said this is a new build. It's possible (likely even) that the BIOS version is for pre-FX series CPU's and the board is not booting because the CPU is not recognized. Is there any chance that you could get your hands on a socket AM3 CPU to test it with? If it boots with an AM3 CPU then you could get the current version of BIOS and flash to the newest version after which you should be able to boot with the FX-8120 CPU.
  16. @scout: The 'device boot led' is lit when I turn the PC on

    @JKat: I've heard people saying this sort of thing but I don't have access to an AM3 CPU and I don't want to be paying £30 just to buy one :( I would have though an AM3+ board would have AM3+ BIOS pre-installed?
  17. @JKat: surely if that was the case with it not registering the CPU then the CPU LED would be lit on the board indicating a problem with it?
  18. your bios should be this one for the fx-8120 the number is 0813 and link to it http://ca.asus.com/en/Motherboards/AMD_AM3Plus/SABERTOOTH_990FX/#CPUS dont forget to choose the right one for the power of your cpu 95 or 125 watts.also witch led is giving a error on the board
  19. Jamdude101 said:
    @scout: The 'device boot led' is lit when I turn the PC on

    @JKat: I've heard people saying this sort of thing but I don't have access to an AM3 CPU and I don't want to be paying £30 just to buy one :( I would have though an AM3+ board would have AM3+ BIOS pre-installed?



    It depends on when the board was manufactured. I have the Sabertooth 990FX board and it did not come with BIOS that was FX ready because I purchased it before the FX processors were realeased. The board you have was most likely manufactured before the new BIOS was available and it may not have the updated version that supports the FX CPU's.

    The minimum BIOS that ASUS lists for your CPU is version 0813.
  20. @scout: thank you, the led's that are lit are the VGA led and the device boot led.

    @JKat: I know that the motherboard doesn't have the right BIOS and I know what BIOS the CPU needs, you are giving no useful information in response to my initial question. I just need to update the motherboard's BIOS to 0813 or 0901 which is the latest one. I don't know how to do that without any display though.
  21. that means it do not see the graphic card could you try the card in slot 3 she is also a pci-e 16 then if nothing goes on we will check something else
  22. I spoke to Amazon earlier (who I bought the board from) and they are sending me another board, I've asked for one that was more recently stocked so hopefully when I get that (which should be soon, it's being sent 1st class) I will check the BIOS number and post on here my progress. Thank you so much to everyone, you have all been a great help!

    @scout: thanks, I'm hoping that when I get this updated BIOS it will recognise everything and if not then I should atleast be able to get into the BIOS and mess about with things, thanks for your help.
  23. @ Jamdude your welcome was a pleasure helping you the best i can
  24. Your time and experience is greatly appreciated, thank you.
  25. OK so I got my new motherboard, read the BIOS # on it staright away and was over the moon when it said the correct number! It now recognises the CPU but as before the VGA LED is lit on the board, there must be something wrong with the graphics card, what do I do?
  26. RMA the GPU for another. Before you do that I would bring it to a local shop first and ask them to test it out. Just so your not waiting for something that is not the problem.
  27. Is there any other way to fix the problem? I called Asus earlier and was on hold for 20 minutes until I hung up.
  28. When you run into a problem like this just think, troubleshoot, troubleshoot, TROUBLESHOOT. Like I said take it to a shop and see if thats the problem. If not then move on to the next part.

    You could even get lucky on a simple google search of your problem. Read all your manuals. I would also just wait how ever long you have to while calling ASUS.
  29. I have searched far and wide on the internet and can't find anything that helps, manuals that came with the GPU are no help either.
  30. I had 2 of that MB that did the same thing after hours on the phone with Asus Tech support, trying every thing, four times, they were great, the boards got returned for refunds.
  31. So what was the outcome?
  32. returned for RMA see my thread "5motherboards all with same problem" to read about my adventure. The last one was dropping power to the USB-PS2 on post causing the problem of not entering bios or booting
  33. Sounds like it could be some use to me, thank you :) I am currently mid conversation with Asus and XFX about the problems I am having so hopefully it will be working soon.
  34. Graphics card was dead, tried in another PC and it didn't work, tried another GPU in my computer and it worked :P Thanks for all the help everyone, you've been a great help.
  35. Jamdude101 said:
    Hi everyone, I've just built my first PC - components are in my signature - and when I power it up all the lights and fans work but there is no signal detected through the HDMI or DVI so I can't access the BIOS or see what's on the screen. The Device Boot LED on the board is lit and there are no beeps when the PC is turned on, please help!
  36. try this first,
    ASUS tech support doesn't even help you, they just keep pushing you for an RMA. BUT THE REAL PROBLEM FOR ALL IS the 3 pin connector for the cpu . That's the culprit, You need to NEVER connect to the cpu power 3 pin female connector to the mobo 3 pin cpu fan male connector . You have to use the 3 pin female connector from the CPU on the 4 pin male connector just to the right of it on the MOBO called the cpu fan optional, it is a 4 pin male, but you use the 3 pin female cpu connector there and the embedded slot that places it in the right direction IS USED leaving 1 pin unused> so spread the word...the 3 pin male connector on the saber tooth FX990 is useless.
Ask a new question

Read More

Motherboards LED Monitor