Closed Solved

My DDR2 2GB ram is 800Mhz but it shows 667Mhz in CPU-Z

Hi,

I Have a PIG31Z motherboard which supports 667Mhz and 800Mhz. I just now upgraded the ram from 1Gb 667mhz to 2gb 800Mhz(not including that old 1GB) in one slot and leaving the other slot free. My problem is i still stuck in that 667Mhz alone,but my new ram is 800Mhz. My processor is E5700(Pentium dualcore) which has 200 as base clock and 800Mhz as FSB and running in stock multiplier giving 3.00Ghz. Also i had 9500GT ddr2 xfx card, Win 7 ultimate, CPU-z 1.59. Now tell me guys where lies the problem....
8 answers Last reply Best Answer
More about ddr2 800mhz shows 667mhz
  1. Have you manually go into the bios and adjust your new ram speed?
  2. rvpctmca: if you have the old 667mhz stick still in the comp, your motherboard will slow the new Stick to accomodate the older sticks Rating..

    Try sticking New ram into all slots on your mobo when you do upgrades.. or just remove the old one.
  3. Ya i manually got into bios but there is no option to select in "Memory Frequency",the only option is "by spd" is available(That is for automatic only)..I am using Pheonix bios.
  4. I dint put that old stick into the motherboard. I put only the new stick and tried all the slots, still have the same problem..Also i cleared the cmos(at the time of upgrade) by removing the cmos battery and leaving system for 15 mins and after that i put that cmos battey back and switched on..from that time it still has this problem..
  5. Is there any problem in CPU-Z 1.59 software showing the wrong thing... Can you tell which optional software will show the correct information..
  6. Best answer
    Never heard of cpu-z botching RAM numbers. If possible, try upping your northbridge speed. That will affect both your cpu and RAM, and may be the only way you can have your RAM run at 800.
  7. Best answer selected by rvpctmca.
  8. This topic has been closed by Nikorr
Ask a new question

Read More

Memory DDR2 RAM Motherboards