Sign in with
Sign up | Sign in
Your question

Asrock P67 extreme 4 gen 3 Ethernet port not working?

Last response: in Motherboards
Share
January 12, 2012 1:54:02 AM

Gentlementlemen -- and women,

I think this is a mobo issue. There is a short and sweet version at the bottom for all the non-readers out there.

Mobo: ASRock P67 EXTREME4 GEN3 LGA 1155 Intel P67
CPU: I 2500
GPU: Radeon 6970 2 gb
PSU: COOLER MASTER GX Series RS750-ACAAE3-US 750W
SSD: Crucial M4 CT128M4SSD2CCA 2.5" 128GB SATA III
Optic: ASUS DRW
RAM: G.SKILL F3-12800CL9D-8GBRL


I have had a few issues trying to build this. The HDD I initially ordered showed up toasted. I'm just using the SSD for now.

I have installed Windows 7 and ALL of the drivers on the accompanying mobo cd. Blah blah boring. I even downloaded some on a laptop and thumbdrived them over. No go.

HERE IS THE PROBLEM: When I plug an ethernet cable in, I can't get on the internet. Windows Network runs its troubleshooter like it's going to try and fix something (pshh.. yeah right) then it says I need drivers. Well guess what? I just downloaded every driver on the interwebs and that has not fixed it. So I say, hey maybe I'll look at the ethernet port... No lights. >< Wish I would've started there. Funny thing is when I was having trouble with the HDD the first go round, the same port worked like a charm! I had installed windows 7 and all that and connected to the internet via the same port, but the faulty HDD had some issues that crashed me and all swtor plans came to naught.

I'm wondering if it's a power issue? (I have no idea, actually) I really don't think it's a hardware thing on the mobo because, like I said, it worked just yesterday...

And, on a much darker note, I actually called Geek Squad about it... I was desperate!

The Short version: Ethernet port doesn't work with all necessary drivers... what gives?

Appreciate any help!
a b V Motherboard
January 12, 2012 4:01:09 AM

Try a new network cable, then try a new router/switch/modem. If that works, problem solved. If that DOESN'T work, try this.

Connect this computer to your laptop via a network cable. NO, this will NOT work for much of anything BUT, it will let you know if the port is bad or if there is something else. The network driver is probably tied to the north-bridge/chipset on the board so trying every random driver out there probably won't help. Next step, try reinstalling Windows again. You can probably forego ALL of the 'software' on the drivers disc and go for the drivers alone.

Let us know how it goes.
m
0
l
a b V Motherboard
January 12, 2012 4:18:12 AM

It comes with a 2 year warranty... a plus...

You downloaded these Win7 64bit drivers, specifically the Realtek LAN driver?

... again 2 year warranty, use it.

m
0
l
Related resources
a b V Motherboard
January 14, 2012 6:05:41 PM

Did you try installing the ethernet driver from the CD that came with the mobo? That driver should work.
m
0
l
February 13, 2012 6:56:06 AM

I had a similar problem.

I had to install the drivers manually. I downloaded, extracted them. Then used Computer Management utility in the Control Panel to navigate to the Device Manager, scroll down to your "other devices" and select the network/ethernet adapter. Right click the adapter and select "browse my computer" to find where you downloaded it.

For some reason my pc wouldn't find the drivers online or on my system. I tried running the Broadcomm Control Suite and that did nothing except tell me there were no network adapters.
m
0
l
!