Closed Solved

Asus p7p55d evo, ram issue

Hello,

I just upgraded my ram from a kingstone 1333 4g to a 1600 2x4 vengeance, first i was having issues fitting them on my motherboard, after i finally put them on i turned on my computer and now it wont even start, the monitor stopped working and theres a red light above the cpu i tried to put my old ones back on and the computer wont start anyway, any help, suggestions? sry for the bad english
4 answers Last reply Best Answer
More about asus p7p55d issue
  1. Best answer
    What are your system specs? How did you have "problems" getting the RAM to fit? I know some Asus boards have a static retention pin for the memory, is that the issue?

    also, try clearing/resetting the IOS and going from there.

    Last and most likely in my opinion: The memory is unsupported. Asus boards can be picky about what memory they use/like. Was the Kingston triple channel and the new stuff dual channel? Other way around?

    Try those things and come back with those answers and we can go from there. Welcome to the community.
  2. thx for the reply puttsy i wasnt putting them correctly problem solved lol thx nyway
  3. Best answer selected by madman_34.
  4. This topic has been closed by Nikorr.
Ask a new question

Read More

Asus RAM Computer Motherboards