Sign in with
Sign up | Sign in
Your question
Closed

Getting stuck on BIOS Screen

Last response: in Motherboards
Share
January 12, 2012 2:24:16 PM

Hello,

I've been having a strange problem with my PC ever since I moved. I transported my computer via car, so I suspect that something got shaken around inside and that's the source of the problem.

When I initially power on my PC it just gets stuck on the bios splash screen, and none of the keys seem to work (can't get into the setup menu and such)--I have a USB keyboard and mouse, if that's relevant. However when I hit the forced restart button next to the power button on my computer, everything boots up just fine. Can anyone give me some pointers on where to start looking to fix this?

System Specs:

Mobo: Asrock P67 Extreme4
CPU: Intel 2500k (OC'd with a bios preset)
RAM: G.SKILL Ripjaws X Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) [F3-12800CL8D-8GBXM]
HDD: SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5"
GPU: SAPPHIRE 100312SR Radeon HD 6950 2GB 256-bit GDDR5 PCI Express 2.1 x16
PSU: Antec TruePower New TP-650 650W Continuous Power ATX12V V2.3 / EPS12V V2.91

Thanks, and I hope someone can help!

More about : stuck bios screen

a b V Motherboard
January 12, 2012 2:32:10 PM

try resetting the cmos?
Score
0

Best solution

a b V Motherboard
January 12, 2012 2:45:05 PM

I would start by shutting down and re-seating everything (GPU, RAM, HDD), except the CPU.

Also those specific Asrock motherboards have been problematic for quite a few people - some people will never have problems, others will have constant problems.
Share
Related resources
January 12, 2012 2:49:23 PM

Thanks, I'll give the above 2 options a shot.

I don't know if the motherboard itself is problematic (unless something happened to it) since everything has worked fine for the past year. At least I hope the mobo isn't fundamentally the problem. I still find it baffling that everything works perfectly after the restart at bios.
Score
0
January 19, 2012 12:04:39 AM

Best answer selected by LordMelkor.
Score
0
a c 329 V Motherboard
January 19, 2012 6:39:20 AM

This topic has been closed by Nikorr.
Score
0
!