Sign in with
Sign up | Sign in
Your question

Could my problem be the heat sink?

Last response: in CPUs
Share
May 10, 2011 6:25:01 AM

Does anyone know how a CPU heat sink could prevent a computer from booting?

Here are the details. I have a Gigabyte GA-MA790FX-UD4P motherboard with a Phenom II X3 710 processor, using the stock heat sink. I upgraded my BIOS to F8G (which supports the latest AMD processors), and ordered a Phenom II X6 1090T processor, but when I installed it the system wouldn't boot. I don't have a speaker in my system, but the disk activity light went into a repeated pattern of four blinks, and the display was never initialized so I didn't get any error message.

I figured that the processor was defective, so I returned it under warranty. When I tried the replacement processor, I got the same error. I then reinstalled my X3 processor, but using the heat sink that came with the X6 processor, and got the same error in that case as well. So it looks like the system won't boot with the new heat sink. The question is why. I've thought of a few possibilities, but they all seem improbable:

1) The BIOS is refusing to boot because it thinks that the CPU fan is not running. I think I've ruled this out because the fan does operate, and when I tried booting with the fan unplugged, the system shut down immediately, rather than making the disk activity light blink.

2) The CPU is overheating. There is no sign of physical damage to the heat sink, but I suppose that the heat pipes could be defective.

3) The clips for the X6 heat sink appear to place more pressure against the CPU that the heat sink for the X3 does. Perhaps this causes the motherboard to bend slightly, causing it to malfunction.

When AMD sent me the replacement processor, they included another heat sink, which I haven't tried. I'll wait until tomorrow to try it (when I'm less tired and hopefully less likly to bend a CPU pin).

More about : problem heat sink

a b à CPUs
May 10, 2011 8:43:03 AM

First off, i am guessing youre system works like a charm with the X3 proc.
The system doesn't POST, stay's silent with the X4 on it.
A fan cannot be the cause for a board to mallfunction other then auto shutdown due to not detecting a cpu fan.


Question:
What is the size of youre bios ?

I have been trolling around gigabyte's forums and seen reports that mainboards with a 4Mb bios size are unable to hold this cpu due to the limitations of the bios size;
Gigabyte cannot fit more cpu parameters in the bios.... (LOL!)

So go and check if you have a 4MB bios first.
m
0
l
a b à CPUs
May 10, 2011 8:51:21 AM

Clear the CMOS (use the jumpers or remove the mobo battery for a few seconds and put it back) and try again.
http://i.imgur.com/gGMqF.gif

Maybe a bad BIOS update, those boards have dual BIOS, maybe the new one didn't install and the reserve one kicked in. Check if your BIOS is really the F8G (all programs/accessories/system tools/system information).
m
0
l
Related resources
a b à CPUs
May 10, 2011 2:10:22 PM

So it is booting into your BIOS but not windows ?

If so then go into your bios and put all settings back to default PressF10 and OK then boot again.

If this fails Power off your PC, remove Cmos battery, power up without battery, then power off again after a few seconds.

Put battery back in, and power on, this should get your windows to boot.
m
0
l
May 11, 2011 4:38:16 AM

Thanks for the replies, folks. I tried the other heat sink, which didn't work. Now when I go back to my original processor and heat sink, that doesn't work either, so my system is dead. I've sent Gigabyte support a message; hopefully they will reveal what the pattern of flashes from the disk activity light means. I'll probably end up trying to get a warranty replacement of the motherboard from Gigabyte.

In response to the questions about the BIOS: The BIOS image for this motherboard is exactly one megabyte (1048576 bytes). The BIOS is definitely F8G; the version is displayed briefly when the system boots.
m
0
l
!