Sign in with
Sign up | Sign in
Your question

[HomeBuilt] What did I do wrong?

Last response: in Memory
Share
January 12, 2012 11:52:15 PM

Alright, so Got my cpu in the mail today and installed it with the cpu fan(with thermal paste of course) and thought everything was ready for boot and all good, checked that everything was plugged in and then continued to close the case.

Booted it up, Blank screen no bios or anything...all fans are on including the cpu fan dvd drive opening and closeing....I just don't know whats wrong.


Here is a full list of everything I have.

CASE- Rosewill challenger.

http://www.newegg.com/Product/Product.aspx?Item=N82E168...(Computer+Cases+-+ATX+Form)-_-Rosewill-_-11147153

Motherboard - Biostar A880g+

http://www.newegg.com/Product/Product.aspx?Item=N82E168...


Psu - Gaming series gs600

http://www.corsair.com/power-supply-units/gaming-series...

Ram - vengeance 8gb

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

CPU-

http://www.newegg.com/Product/Product.aspx?Item=N82E168...


What did I do wrong? :\ :fou: 

More about : homebuilt wrong

a b à CPUs
a c 146 } Memory
January 13, 2012 12:02:48 AM

Do u have the HDD plugged in?

Check the 8pin connection.
m
0
l
a b à CPUs
a c 146 } Memory
January 13, 2012 12:03:51 AM

Any light is ON on the mobo? Any beep? Do u have a case speaker?
m
0
l
Related resources
January 13, 2012 12:06:08 AM

I was told that I did not need an hdd to go into bios, But I will be getting one this sunday....and no there are no lights on the mobo...I did get a little speaker with the mobo I will plug it in and check again.
m
0
l
a b à CPUs
a c 146 } Memory
January 13, 2012 12:08:02 AM

Assassinseye1 said:
I was told that I did not need an hdd to go into bios, But I will be getting one this sunday....and no there are no lights on the mobo...I did get a little speaker with the mobo I will plug it in and check again.

I thing that is it. Borrow an HDD and u will know.
m
0
l
January 13, 2012 12:27:56 AM

technically you should be able to access the bios without a hdd but doesn't mean you can. Depends upon manfactures settings. If you can't get to a hdd quickly just to test, I would recommend removing the mob from the case and attempt to boot. If it works make sure your case is grounding correctly.
m
0
l
January 13, 2012 1:05:11 AM

Hmm, Ill just prob end up going to the pc store and have them take a look...Im also thinking the ram is the problem
m
0
l
a b à CPUs
a c 146 } Memory
January 13, 2012 1:06:53 AM

Do u have a DVD drive or USB pendrive? Try it.
m
0
l
a c 172 à CPUs
a b } Memory
January 13, 2012 5:22:38 AM

You do not need a hard drive, monitor, keyboard, or mouse to successfully complete the POST (single short beep).
m
0
l
January 13, 2012 5:26:16 AM

my first thought would be ram make sure you have a dimm in the first slot and if so try swapping them
m
0
l
!