Sign in with
Sign up | Sign in
Your question

Asrock 970 xtreme 3 wont post

Last response: in Motherboards
Share
January 14, 2012 12:31:34 AM

I tested my graphics card on my friends computer. Its a gtx 550 ti. Its not the graphics card problem obviously. When i turn the computer on the fans turn on and stuff. Ram is in securely. All the psu cords are firmness in. Im thinking the motherboard is faulty. The Atx 8 pin power for the cpu uses 2 psu 4 pin connectors.

More about : asrock 970 xtreme wont post

a b V Motherboard
January 14, 2012 1:38:05 AM

Does your PSU have an EPS12v connector or...If it's the 2, 12v 4-pins combined, it's an EPS12v connector.
The correct description would be "ASRock 970 won't POST" Posting is basically the board initializing and proceeding onto the OS.

Try removing all but one stick of RAM and try it again, then try and use integrated graphics (if avaliable) and see what happens. Also, disconnect, then reconnect all power connectors from the board and remove all unnecessary peripherals/add-in cards.

Next, clear the CMOS/BIOS and see if you can get in then, after that, look into dumping the BIOS if your board supports it. Next up, post more system specs and we can see if everything looks Kosher.
m
0
l
Related resources
January 14, 2012 1:48:48 PM

I have a amd 4100 cpu. 8gb g skill ram. seagate 500 gb barricuda.
m
0
l
a b V Motherboard
January 14, 2012 11:58:16 PM

Try a new PSU if you can. That's my next guess. Disconnet all non-essentials from the board. (RAM, Graphics, ODD, HDD, SSD, SATA cables, etc...) and see if that makes a difference. Next, it is an FX 4100, correct? If so, try using integrated graphics and see if that does anything. Yes, you think you're video card is "obviously not the problem" BUT, there could still be compatibility issues or, a problem with the port/slot on the board. Let us know what you find from that and we can continue on! Also, make sure the board is not shorting out on anything, that could be the problem as well.
m
0
l
January 15, 2012 6:21:21 PM

i tryed a new power supply. nothing. there is no intergrated graphics. we tryed 3 different graphic cards out.
m
0
l
February 12, 2012 9:06:08 PM

one thing needs to be clear has this motherboard ever posted to if not check to make sure your stand offs r in the right place and no part of the motherboard is touching the case i mean the bottom off your mother board 2 if it has not posted try using a diff cpu some mother board have to have there bios updated before they well suport the new amd bulldozer.
m
0
l
February 16, 2012 3:46:30 AM

OP,

I recently got my Asrock 970 extreme3 as well. I tried 2 different Graphics cards, and I have the same ram as you. I am using my motherboard outside of the case, so when I short the front-panel power, my pc turns on. I am getting fan movement, but no video. If anyone has an idea of whats going on, please post. First-time Builder in distress here :) 

PS: Nothing on the Guide works for this problem
m
0
l
October 13, 2012 5:22:23 AM

Howdy

My build is very similar ( i posted this issue a few days back). Asrock 970 extreme 3 mobo and fx4100 bdozer.

I have tried all options also, but eventually went ahead and ordered a cheap sempron cpu (am3 socket compatible with mobo) from overclockers. From what i read some mobo's need a bios update before they will work with the fx4100. I hope when the cheap CPU arrives on monday, the mobo will post and ill be back in business. Ill let you know if it worked.
m
0
l
November 3, 2012 1:34:48 AM

I have nearly identical build, brand new ASrock 970 Extreme 3, refurbished new AMD phenom II x4 965 deneb 3.4ghz, New 500W PS (I have two and have tried both, they both also work in other machines) G skill f3-12800cl9q-16gbrl.

I've tried without video card, no beep code, tried moving ram around in all combinations of slots and individual sticks and each combination of two sticks at a time.

The only time I even get a beep code is with no memory, at which point I get the normal 3 beeps. Any ideas? I'm halfway thinking about the processor but really don't want to pay to ship it back on RMA if I'm not pretty sure. The RAM and Board are brand new out of box though. This is all breadboxed.
m
0
l
!