Sign in with
Sign up | Sign in
Your question

Display Driver AMD stopped responding and has recovered! - Gaming

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
a b Ý World of Warcraft
December 12, 2010 12:17:41 PM

Ok



So I just bought myself a brand new computer with windows7 home 64-bit os. And ever since I first time booted it up and started playing WoW I have been troubled with this mind-numbing error "Display driver AMD stopped responding and has recovered". The error occours randomly. Sometimes frequently other times rarely. The synthomps of the error while playing is that the graphics freezes up for about 3-5 seconds, following a black screen (Sometimes other random colors aswell) and then recovers, running the game normally again.



Yes I have uninstalled "old" drivers and sweeped them out, and innstalled fully updated ones. My components are not overheating nor overclocked, I have actually tried to DOWNclock components including GPU, CPU and RAM, not to resolve anything. I have tried to edit registry keys trough the timeout detection and recovery feauture (http://www.microsoft.com/whdc/device/display/wddm_timeo...). I have deleted the interface, Cache and WTF folder in the WoW folder and ran the repair tool. And last, I tried to run WoW in OpenGl mode. None of these steps have had a slight effect on the cause of resolving this error. Tho, changing the DRAM/PCI frequency from unengaged to engaged mode seems to stall the errors alittle



I have searched hardware and software forums endlessly the last couple of days, trying to find a solution or at least a diagnose of what causes the error.

If anyone could help me diagnose/resolve the error. I would be very very gratefull. I am willig to try out more advanced steps if you have any suggestions. Everything from changing BIOS settings to modify registry keys.



NB: I have thus so far never been troubled with this error using other games/applications than World of warcraft.



Operating System

MS Windows 7 Home Premium 64-bit

CPU

AMD Athlon II X3 445 23 °C

Rana 45nm Technology

RAM

4.0GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)

Motherboard

MICRO-STAR INTERNATIONAL CO.,LTD 770-C45 (MS-7599) (CPU 1)

Graphics

SAMSUNG @ 1920x1080

ATI Radeon HD 5700 Series (5770)

Hard Drives

1465GB Seagate ST31500341AS ATA Device (SATA) 28 °C

Optical Drives

No optical disk drives detected

Audio

Realtek High Definition Audio


PSU is 750W



Thank you in advance!
March 30, 2011 8:33:13 AM

HI,

I have the exact same problem on a W7 64 bit machine with Intel core i5 processor.

I am looking for an answer too!
Related resources
!