Sign in with
Sign up | Sign in
Your question

HD 5900 series Driver Problems

Last response: in Graphics & Displays
Share
December 13, 2010 3:42:37 PM

Hello all

I have a HD 5970 and it has always worked fine. Recently windows update installed a windows driver update for HD 5900 series released in October. The install failed and I left it Ever since then the screen flickers from side to side for a few seconds when the PC starts up, shuts down or I open the catalyst control centre.

Now Ive tried uninstalling the device and software through the device manager and reinstalling the most recent drivers from ATI but with no luck.

Can anyone help please, this is driving me mad!

Thank You

James
a c 218 U Graphics card
December 13, 2010 3:56:59 PM

Go to ati.com and download the latest drivers (Catalyst Suite) for your flavor of Windows. NEVER use the Windows Update provided video drivers.

You may need to run driversweeper (http://www.guru3d.com/category/driversweeper/) first to remove the current config in order to get the current version installed properly.

Good luck!
December 13, 2010 4:17:11 PM

I gave that a go, I used guru3d and removed the current stuff, installed the most up to date drivers from ATI, I reboot and the problem is still there. If I go on the device manager it still says it has the October drivers installed. I just cant seem to get rid of them!
Related resources
a c 218 U Graphics card
December 13, 2010 4:23:18 PM

In Device Manager, right click on your device and select uninstall. If asked to remove drivers, say yes. Don't restart yet.

Next, reinstall Catalyst, selecting the custom install. Click on the box (you'll see what I mean) to select all items in the install. When complete, restart.

This should do the trick.
December 13, 2010 4:41:58 PM

Right, I tried that and I think I see whats going wrong. when I removed the device and drivers from the device manager before I had a chance to reinstall the ATI drivers the windows notification window opened on the task bar telling me that it was installing device driver software. I think it may be putting its own ridiculous drivers back on straight away. Suffice to say i removed it again and installed the ATI drivers. I started back up and the problem is still there. I assume windows is installing its drivers as soon as it reboots. Is there any way I can stop it from doing this? Thanks for the help so far, I cant believe how annoying this is! :) 
a c 218 U Graphics card
December 13, 2010 4:51:55 PM

Upon restart, is Catalyst running? If so, what driver version is it reporting? I assume you are looking at Device Manager for this information otherwise.
December 13, 2010 4:56:11 PM

Catalyst is running on version 10.11 . Im going to try version 10.10 to see if its maybe just an issue with the latest drivers. Not sure what else to do now.
a c 218 U Graphics card
December 13, 2010 5:03:14 PM

Whittles said:
Catalyst is running on version 10.11 . Im going to try version 10.10 to see if its maybe just an issue with the latest drivers. Not sure what else to do now.

So, what software version is Catalyst showing in the Info Center/Software tab? Does it show 10.11 or the MS provided version?

Also, what PSU are you using and what are your overall system specs (CPU, memory, OS, etc)? And, are you overclocking anything?
December 13, 2010 5:10:59 PM

It is showing 10.11 in the info centre/software tab not the MS version. The PSU is 1100 watts. My overall set up is an i7 920 overclocked slightly, 6GB RAM, HD5970, windows 7 prof 64 bit. I have also recently installed a new sound card as my old one died. Its a creative x fi titanium. However this issue began after windows update did its thing. I never meant to install a windows driver for the GPU I just selected the lot and didnt check (stupid I know).
a c 218 U Graphics card
December 13, 2010 5:19:15 PM

You aren't the only one, it has happened to us all (whether we admit it or not), including me.

OK, so now we have the correct version installed. This is a good thing.

Is the problem still occuring? If so, I think we have a coincidental issue going on.

Double check that your monitor connections are secure and tight. BTW, how are you physically connecting your GPU to your monitor (VGA, DVI, HDMI, or DisplayPort)? Are you using any adapters?

Also, do you have another monitor, on another system, that you could swap to rule out a potential issue with the monitor itself?
December 13, 2010 5:34:22 PM

Im linked up via DVI and Ive tried another monitor but still the same issue. Really at a loss now, maybe there is a hardware problem that just happens to have manifested itself at the same time as windows update cursed my PC.
a c 218 U Graphics card
December 13, 2010 5:42:30 PM

Whittles said:
Im linked up via DVI and Ive tried another monitor but still the same issue. Really at a loss now, maybe there is a hardware problem that just happens to have manifested itself at the same time as windows update cursed my PC.

Something just popped into my head (my wife would be amazed that anything goes on between my ears). Go into Catalyst and disable (uncheck) the setting to auto-detect monitors (should be in the displays/desktop areas). Sorry I can't be more specific, not at a system with Catalyst running on it.

The MS driver may have tweaked these settings and now your new driver install is redetecting the monitor each time you start/shutdown/run Catalyst.
December 13, 2010 5:42:43 PM

Right, I dont want to speak to soon but I think I've resolved the problem. I got rid of the microsoft visual c ++ x64 redistributable 10.0.3 and re installed it from ATI's catalyst package and that appears to have cured the problem. Im sure its just microsoft tricking me into a false sense of security and bam its going to totally fail tomorrow. Thank You very much for your time and help, it is very much appreciated. Ill post if its still working tomorrow and then if so I suppose that must have been the problem.

Thanks again

James
a c 218 U Graphics card
December 13, 2010 5:45:38 PM

Good luck! I am pulling for you.
December 13, 2010 5:45:42 PM

Ah in reply to your last post I think that may have been the issue as that option was always on auto detect previously and since I reinstalled the microsoft visual c ++ it seems it is no longer selected any more, maybe that changed when I reinstalled all the drivers again along with the microsoft visual c ++ . I think you got it there! Thanks ever so much!
a c 218 U Graphics card
December 13, 2010 5:48:22 PM

Whittles said:
Ah in reply to your last post I think that may have been the issue as that option was always on auto detect previously and since I reinstalled the microsoft visual c ++ it seems it is no longer selected any more, maybe that changed when I reinstalled all the drivers again along with the microsoft visual c ++ . I think you got it there! Thanks ever so much!

[8-)

We shall see, my friend. Have fun!
!