Closed Solved

GTA 4 Lagging on i7

Hi guys.
I recently bought myself the Asus Rampage III Formula mobo, the Intel Core i7 960(3.2Gighz Quad Core) and 3 Gig of DDR3 (1600mhz) Ram. Gta 4 is lagging when i play, yet i get 57 FPS or so in the Benchmark.
My other friend, experiences the same traumatising effects :-D. He has the Intel Smackover I mobo, 2.66 Core i7 and 4 Gig of DDR3(1800mhz) Ram.

The lag as such is when you change direction of movement (like turning the wheels in a car, and when you suddenly press "D" or "A" to turn when on foot).

We both running Windows 7 Ultimate, 64-Bit. Games like COD Black Ops runs great at maximum graphics. Same story with Crysis 2.


If any one can help me get the problem sorted out, it would be much appreciated.
Thanx !
18 answers Last reply Best Answer
More about lagging
  1. well first of download the latest drivers from your gpu card manufacturers site.
    Second you could defrag your hdd.
  2. you havent told us of your gpu model/brand?
  3. Drivers : 190.38 Forceware.
    Defragged : Formatted like 5 Hours ago...
  4. Its a Leadtek GTX260 Extreme+ on my machine,
    and a Gigabyte HD4800 ATI card for the friend
  5. GTA IV suffers from some bad coding issues.. Thus the lags you are getting might not be any hardware issue.. Having said that, both of your rigs are quite capable of handling the game smoothly.. How much of video memory do your video cards have.. This game is good with at least 1 GB of video memory.. Also, if you have HT turned on, try the game after turning HT and other stuff like ESS turned off..
  6. you have 3gigs of ram?Do you have a 1gig ddr3 ram module?
  7. I have 3x 1Gig modules. They are running in Tri-Channel.
    The friend has 4x 1Gig modules
  8. yes you coulld do what Emperus says.Switch of HT in the bios.
  9. Okay. I turned off my HT, yet it still lags. The game runs great, untill you make sharp turns, like i said in my original statement.
    Personally, i think it is Windows itself. I used to play it nicely on my Core 2 Duo(3.00Gighz) and it ran smoothly.
  10. turn down the draw distance to 50 this has the biggest impact on the games smoothness.
    it could be your running low on gfx mem if thats set to high. another thing is i have a 5870 and i cant max the game out most of the settings i run are at 75% of max. so try lowering them a bit.
    you may also want to check the power settings... make sure its not set to 100% idle or your cpu will be constantly trying to downclock.
  11. The GTX260, from what I can tell, has 898MB of RAM. Its a bit low honestly for GTA IV. I remember when it came out my HD2900Pro 1GB wasn't enough. It uses something like 700-800MB of RAM at recommended settings, which were medium-high.

    It has optimized a lot though and my HD5870 can take it. But you might want to update your GPU drivers. They are on 270.66 I believe.
  12. Best answer
    YOU ARE ALL WRONG UNLESS YOU HAVE SAID TURN OFF WINDOWS EVENT LOG.
    I say that in all caps because i know that it will fix his problem. How do i know this? i have had the problem on three laptops all capable of playing gta4 on medium high settings that displayed the exact problem that he described.

    turn off windows event log under the windows services. but beware you will not have reliability monitor and other luxuries afterwards.
  13. Or you could try buying a legit version of the game...It will run so much better than the pirated one, trust me
  14. not that I'm against a good pirated game, but this one seems to be a real pain work with...
  15. is it a legit copy if you legally obtained a pirated copy?
  16. Best answer selected by j0K3rsa.
  17. Sorted out. Thanx cbrunnem... :-)
  18. This topic has been closed by Mousemonkey
Ask a new question

Read More

CPUs Lag Intel i7