Sign in with
Sign up | Sign in
Your question
Closed

My games won't work (4870x2 w/ WHQL Drivers)

Last response: in Windows 7
Share
May 13, 2009 4:06:07 AM

Why is this happening? I did a clean install of Windows 7 64-Bit. I installed the latest WHQL drivers. I made sure all my drivers were up to date in my device manager. Then, I installed Crysis, Bioshock, and Fallout 3. All 3 either crash or have dots during gameplay with light rays shooting out of everything.

Prior to this, I was running Windows 7 32-Bit which I did as an upgrade from Vista. When I did this, I had a bunch of games (Demigod, Far Cry 2, Fallout 3, Crysis, Bioshock, Assassin's Creed, Grand Theft Auto 4, All the Valve stuff, etc, etc). None of them worked. I had the latest WHQL drivers at that point as well.

I thought a clean install of the 64 bit edition would solve my problems. It didn't.

Here are my specs:

MSI P45 Platinum Motherboard (1.10 BIOS *latest*)
4870x2 (WHQL Drivers)
4 GB Corsair RAM
Intel Q9300 Quad Core CPU (Not overclocked)
Wester Digital 500 GB SATA HD


Please help me... I miss my games :-(
May 13, 2009 11:17:26 PM

Try running in compatibility mode
Score
0

Best solution

May 17, 2009 2:53:34 PM

I figured it out! I'll post because maybe someone is having the same problem. I needed to install the Catalyst Control Center. As a way of reducing the amount of processes, I always installed the driver only and never CCC. Now that it's installed, these games are running smooth as eggs!
Share
Related resources
!