New memory won't work in system

Hello all,

I have a gigabyte ga-880gm-usb3, and I just got my new sticks for it,but when I plugged them in,my computer won't boot,I dried arranging them differently.but it is to no avail. I got the G.Skill RipjawsX PC3-12800 8gb.

Are these sticks just incompatible with this board? Or do I need to RMA them?

ga-8880gm-usb3
G.Skill RipjawsX
7 answers Last reply
More about memory work system
  1. nikorr said:
    Can u reset the BIOS?
    How To Clear CMOS @ http://pcsupport.about.com/od/fixtheproblem/tp/clearcmos.htm

    Well I am on the computer currently,it already has 2 sticks in it,I am trying to add these other two,should I still do a reset?
  2. mufasa said:
    Well I am on the computer currently,it already has 2 sticks in it,I am trying to add these other two,should I still do a reset?

    I would start with that, since u have re-seated them already : )
  3. nikorr said:
    I would start with that, since u have re-seated them already : )

    Ok,I loaded fail safe defaults and used all four sticks in various combinations,and couldn't get it to post,I have one old and one new stick running currently[4gb ea] and my computer sees the 8 gb of ram. what should the proper set up of sticks should it be:
    slot1: old
    slot2: old
    slot3: new
    slot3: new
    or
    slot1: old
    slot2: new
    slot3: old
    slot3: new
    in the manual it says that channel 0 is slot 1 and 3 and channel 1 in slot 2 and 4
  4. The Sticks work fine,I tested them individually in separate slots,so they're not dead.
  5. It could be also the CMOS battery.


    BTW, whats the PSU?
  6. The system is pretty new and has been working flawlessly since I got my new GS-600 Corsair.At the same time earlier today I installed a new VGA an xfx 6850.
Ask a new question

Read More

Memory Product