Sign in with
Sign up | Sign in
Your question

ASUS USB 3.0 Front Panel Box Problem

Last response: in Motherboards
Share
January 16, 2012 9:08:59 PM

I have an ASUS P8P67Pro motherboard. I purchased an ASUS USB Front Panel Box and connected it to the 19 pin header on the motherboard. My problem is that when I plug my WD MyPassport into it it doesn't get recognized. The power light does come on though. If I connect it to the USB 3.0 port on the rear of the board it works fine. If I connect my Seagate USB 2.0 Free Agent to the Front Panel box it also works as it should. I updated the Renesas driver but still no go. I also do not see the additional USB 3.0 ports showing up in device manager. Any thoughts?
January 16, 2012 9:24:47 PM

Maybe the HDD is not getting enough power.
m
0
l
January 17, 2012 8:33:14 PM

Maybe, but why does it work on the rear ports? Is there a difference in the amount of power the ports put out?
m
0
l
Related resources
January 27, 2012 2:26:58 PM

deertroy1 said:
I have an ASUS P8P67Pro motherboard. I purchased an ASUS USB Front Panel Box and connected it to the 19 pin header on the motherboard. My problem is that when I plug my WD MyPassport into it it doesn't get recognized. The power light does come on though. If I connect it to the USB 3.0 port on the rear of the board it works fine. If I connect my Seagate USB 2.0 Free Agent to the Front Panel box it also works as it should. I updated the Renesas driver but still no go. I also do not see the additional USB 3.0 ports showing up in device manager. Any thoughts?

Check your BIOS to enable the Onboard USB 3 header. Also check under Computer Management/Disk Management to see if it shows up there
m
0
l
February 3, 2012 7:59:50 AM

USB 3 is enabled in BIOS. I returned it to ASUS.
m
0
l
!