Coolmaster Hyper 212 Problem - Help

Hello,

Just replaced my Stock CPU fan with a Coolmaster Hyper 212 Plus , now when I turn power on - my computer powers up all lights, fans, etc.. but nothing comes up on screen.... have checked all connections and even connected a spare monitor to test but nothing.

Just prior to me doing this was working fine,

Any suggestions, I’m thinking I should pull off the coolmaster and check the CPU, not sure what I should be looking for?

Was very careful cleaning off the old thermal paste and replacing it with a thin new layer, the fan on the Coolmaster Hyper spins and is seated correctly.


Running a Intel Core I7 2600K
Asus P8P67 Pro Intel P67 Board

Thanks
6 answers Last reply
More about coolmaster hyper problem help
  1. read this sticky
    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems

    first thing I always try is pulling the memory sticks
    and reinstall one and trying to boot
  2. Do you get the usual single post beep that the system has been tested and functional ?
    Or do you see hard drive activity indicating the system is loading an OS?
  3. is your 4 pin motherboard power connector plugged in?
  4. Did you reseat the CPU after cleaning off the old paste ? if you did look at the motherboard pins. I have my fingers crossed for you.
  5. I sure hope it just isnt pulgged in...ouch
  6. Thanks for everyones feedback, i ended up taking off the Hyper 212 Plus,re-installed it and reseated the memory sticks, it booted up but went straight to the Bios screen , no hard drive detected, i checked the connection to the hard drive, looked good, tryed again and booted up all ok!?

    Fingers crossed all will be good now.
Ask a new question

Read More

CPUs