Sign in with
Sign up | Sign in
Your question

APEI: Can not request iomem region region

Last response: in Motherboards
Share
January 18, 2012 2:28:59 PM

Hi, I'm just googling this problem.

I've just ran a preupgrade on my box (Supermicro 7046A) and I'm now getting this on boot:

Loading Linux 3.1.9-1.fc16.x86_64 ...
Loading initial ramdisk ...
[2.135273] APEI: Can not request iomem region region <00000000bf795eba-00000000bf795ebc> for GARS

It always ran this message but now on reboot it's halting at the message.

Does anyone know of kernel arguments I could pass in to disable the request (based on what I understand this has never worked so presumably there's no impact to disabling the function).

Or if there's some bios setting that would allow the function to succeed.

I'm going to post this in the FC16 support forum as well as the supermicro support forum and if I find anything interesting I'll follow up from there if anyone is interested?
March 12, 2012 7:55:02 AM

I know this is a couple of months old now, but I'm not seeing anybody address this yet.
I'm definitely interested in in a resolve for this as well. I've installed CentOS 6_2 Linux Kernel 2.6.32-220.7.1el6.x86_64 on a SUPERMICRO X7DVL-E and get the same message, but no halt yet.

Prior i had installed CentOS 5_7 Linux Kernel: 2.6.18-274.el5.x86_64.

The resolve was to add:
acpi_mcfg_max_pci_bus_num=on
to the Kernel line in grub

This no longer has any affect in the new kernel.
This has to do with the memory hole setting in the bios. Its not something that can be disabled in bios you can only change value. It is a mtrr missmatch compensation for 32 bit OS with 4 gig or more of memory installed from what I understand.
I think this what is causing message in var/log/messages

mcelog: failed to prefill DIMM database from DMI data

At the moment, it does not seem to have any detrimental affect, but I would hate to see this become a problem down the road.

Anyone else know if this issue?
November 20, 2012 7:34:01 AM

Hi. I just ran into this problem yesterday with a HP ProLiant server.
The solution for CentOS 6 is to append "erst_disable" to the kernel command line.
This will generate a "ERST: Error Record Serialization Table (ERST) support is disabled." in dmesg but, theoretically, should fix any freezing problem.
!