Sign in with
Sign up | Sign in
Your question

Asrock Extreme 3 Gen3 "Reboot and Select proper Boot Device" Problem

Tags:
  • ASrock
  • Boot
  • Devices
  • Motherboards
Last response: in Motherboards
Share
January 18, 2012 7:45:56 PM

I just got the remaining parts to put together my upgraded PC. Heres the specs for starters:

Mobo: ASRock z68 Extreme 3 Gen 3 http://www.newegg.com/Product/Product.aspx?Item=N82E168...
Memory: G.SKILL Sniper Low Voltage Series 8GB http://www.newegg.com/Product/Product.aspx?Item=N82E168...
CPU: Intel i5 2500k http://www.newegg.com/Product/Product.aspx?Item=N82E168...
PSU: OCZ ModXStream Pro 700W http://www.newegg.com/Product/Product.aspx?Item=N82E168...
GPU: EVGA 9800 GTX+
HD: Western Digital Raptor WD740ADFD 74GB 10000 RPM http://www.newegg.com/Product/Product.aspx?Item=N82E168...
NO OPTICAL DRIVE

I put it all together and booted it up and got the black screen that reads: "Reboot and Select proper Boot Device or Insert Boot Media in Selected Boot device and press any key." I already have Windows 7 64bit installed from previous config, so I went into my Bios and checked to make sure it was booting from the WD Raptor which it was. Right now I'm putting the ASRock installation CD on a USB drive since I don't have a Optical drive on my PC (using my laptop right now), but I don't think that will fix it. The biggest USB drive I have is a 8GB drive so I don't know what I can do right now to fix this... Any thoughts?

More about : asrock extreme gen3 reboot select proper boot device problem

February 28, 2012 9:51:33 PM

Have you tried booting without the flash drive plugged in? So, is the HDD from a previous system?

Ensure that the boot order is correct, as in booting off of the HDD. You may need to reinstall your OS to make sure all drivers are correct. :bounce: 
m
0
l
!