Sign in with
Sign up | Sign in
Your question

Cannot access shared folders that are on a Windows 7 system

Last response: in Networking
Share
July 7, 2010 7:15:42 PM

Ok. I have a computer on the wired network that is running Windows 7 Ultimate x64.

I right clicked on a drive and clicked "Properties".

I then clicked the "Sharing" tag and then the "Advanced Sharing" button.

I checked off the "Share this folder" box.

I clicked the "Permissions" button and the only option for the Group was "Everyone". All three boxes under "Allow" are checked off.

I have turned off password protected file sharing.

All the other computers can see this shared drive but when they click on it they are told they either need a password or do not have permission to view the folder.

I've tried accessing it with XP, Vista, and 7.

All the other computers can view, upload, delete, etc to my Public folder.

Any ideas?
a b $ Windows 7
July 8, 2010 5:54:51 AM

aaron7 said:


All the other computers can see this shared drive but when they click on it they are told they either need a password or do not have permission to view the folder.

I've tried accessing it with XP, Vista, and 7.

All the other computers can view, upload, delete, etc to my Public folder.

Any ideas?



[#0005ff]Have you set the main C:\ drive to be shared? The start of the path has to be shared as well as the end of it. Are you using the Homegroup or conventional networking?[/#000ff]
m
0
l
July 14, 2010 11:21:24 PM

What is the NTFS permissions set to? (this is under the security tab next to the sharing tab on the properties of the Drive/folder)
The account in this case the "everyone" account need to have local access to the files before that account can have sharing access

If the drive your are talking about it the C drive with the windows folders and stuff, I wouldn't want to give the "Everyone" account access.
If you have the same User names and passwords on each of the computers, I believe you can just give those accounts access and it automatic will log you in to the remote computers. (But those accounts need to have local access to the files your want shared as well as sharing access)
m
0
l
Related resources
July 14, 2010 11:39:31 PM

http://www.howtogeek.com/howto/windows-7/share-files-an...

It can be a pain to network with windows7 if you have a apple especially! I had problems connecting my xbox until I updated XBMC, so try updating your xp computers and fallow the link above. If you wan't to connect a mac have fun, it's a pain but is possible, you just need to manually connect to the shared files everytime.
m
0
l
Anonymous
a b $ Windows 7
December 31, 2012 4:23:01 PM

You said all 3 boxes are unchecked with Everyone ( this mean if Everyone is the only one in the list, that no one has access automatically). If you want to make it available for your other PC's you will need to add an account to the list ( for example your own, only risk involved here is that you will have to allow your user's password to travel on the network ).
So you click add, then type your user in it
( if you don't know it press (windowskey)+(R) type "cmd" in the box and then type net user and you will normally get all names of the users on your local computer )
Then check the permissions you want if this account is used to access it.
!!!! IF YOU MADE AN ACCOUNT OR USED A DIFFERANT ONE YOU NEED THE SECURITY SETTINGS TO BE SET RIGHT
If a different account but your own you need to made sure that that account also actually has access to it ( so you will need to add him to the list in the security options of the file )

The other comments where they say to change the password protection is just like taking your Everyone with all boxes almost, the one I gave is more complex but more adjustable and somehow safer.
The comment with having to share the directory above it is not nessecery all, advanced sharing does is makes a link to that specific folder and gives it an address to access ( \\[your pc name]\[name of the shared folder in advanced sharing] )

I hope this is the answer you are looking for :) 
m
0
l
January 21, 2013 9:37:42 AM

me also having the same problem for accessing share folder. The problem is only with Windows7, on windows xp its working.. Please give me a solution
m
0
l
May 17, 2013 2:56:35 AM

navneetkp5 said:
me also having the same problem for accessing share folder. The problem is only with Windows7, on windows xp its working.. Please give me a solution


m
0
l
May 17, 2013 3:08:52 AM

Did anyone get a solution to this problem? I now exactly the same issue. I have been sharing folders on XP boxes for 7 years or more. Have recently upgrade to W7 64bit and now get permission issues.
I have 4 PCs set up the same. 2 work, two don't. One did but has started not working this week...no updates have been run.
In all cases I am trying access the share folders on macs. Sometimes if I restart the PC then I can access share folders for a limited time then I get blocked.
Really frustrating so any help very much appreciated.
m
0
l
August 28, 2013 11:20:15 AM

This works for me:

Right-click folder > Share with > Specific people > in the drop down menu bar, select "Everyone" and click add > hit ok

This should give all on network access to folder without the need to give access to the C: drive to everyone. Hope this helps.
m
0
l
August 28, 2013 2:11:38 PM

Be sure that your Windows 7 computer is not in a Homegroup, as Windows will limit sharing on non-public folders to only machines that are members of the Homegroup. If your network connection type is set to Home, then you will use the Homegroup settings unless you go to the Advanced Networking Properties and change from "Allow Windows to Manage Homegroup Connections" to " Use user accounts and passwords to connect to other computers". Also, Network Discovery and File and printer sharing should be enabled under the Advanced Networking Properties.

Alternately, you can change your network connection type from Home to Work, which will bypass the Homegroup settings and allow you to share folders with non-homegroup connected machines.

Note that these settings are different for Home and Work networks, Public networks and Domain networks. Be sure to choose the proper settings in the network profile that applies to your network.
m
0
l
October 8, 2013 9:26:55 PM

from the main computer that is running on windows 7 ... go to that folder that you are trying to share (example) "PUBLIC" folder - right click - advanced sharing - then collapse the "home/workgroup" then drop down the arrow on "PUBLIC" then at the lowest part of this tick "turn off password protection"


then that's it... everyone can access the files that you are trying to share
m
0
l
February 23, 2014 3:03:39 AM

Rek Aviles said:
This works for me:

Right-click folder > Share with > Specific people > in the drop down menu bar, select "Everyone" and click add > hit ok

This should give all on network access to folder without the need to give access to the C: drive to everyone. Hope this helps.


Thanks a lot! After selecting "Everyone" in the drop bar it worked like charm for me! Cheers!
m
0
l
!