Sign in with
Sign up | Sign in
Your question

ASRock Extreme4 Gen3 is frustrating me, help please

Last response: in Motherboards
Share
January 19, 2012 4:22:50 AM

Just got in all my stuff to build my new computer and this motherboard is giving me a hell of a time. I have owned well over 20 motherboards in my time from MSI, Asus, and Gigabyte and have never had this issue.

Everything works hardware wise with the excpetion of my keyboard and mouse. First of all the motherboard absolutely does not recognize my Razer Mouse and keyboard. If I plug in a generic mouse and keyboard they work in the bios, but do not work outside of that so I can't log into windows. If I turn off the legacy USB option in the bios the keyboard will now work so I can log into windows but the mouse won't work.

I have tried 5 different sets of keyboards and mice and messed with all the options in the bios that I can think of and nothing works. The fact that I can't install a new motherboard and the bios will not recognize the mouse and keyboard is absolutely rediculous.

I have gone to ASRocks website and the few forums they offer plus I have read everything I can think of. This is so frustrating.

Any help would be greatly appreciated.
a b V Motherboard
January 19, 2012 7:39:04 PM

Have you tried different USB ports? Are you using a USB3 port by any chance? What about a PS2 keyboard or mouse?
m
0
l
!