Sign in with
Sign up | Sign in
Your question

Old Linksys Router Not Recognizing MAC Address

Last response: in Networking
Share
July 8, 2010 5:04:07 PM

I have an old Linksys router (WRT54GS v6.0) that I'm trying to connect my Motorola Droid to via WiFi. My previous phone connected fine, but when I try to enter the MAC address of my new phone into the MAC filter list, it tells me that the second digit must be even. The first set in my MAC address is 45, which seems somewhat unusual but this is how I received it from the store and haven't done anything to it since.

I tried disabling the MAC filter and just connecting the device wirelessly that way, but it refused to connect. I assume it is ignoring the device as it does not recognize its address as being valid. I flashed the router with the latest firmware from the Cisco/Linksys support site, but that didn't help either. I also tried backing up the settings and editing them manually, but the settings are output in a binary file.

I know that a potential workaround to this is to connect the device directly to the router and then add the address as the router displays it, but to my knowledge there is no way to connect this phone to the router with a wire (it has only a USB cable).

Is there any way I can get around this? Thanks for any help.
Anonymous
July 8, 2010 8:17:13 PM

The solution is to stop using the MAC ID filter because it causes problems and is easily spoofed anyway -- I don't quite understand why the router is having a problem when you do that and would suggest pressing the reset (which is obligatory after updating the firmware).
!