Sign in with
Sign up | Sign in
Your question

Underperforming Rig?

Last response: in Graphics & Displays
Share
December 17, 2010 2:39:45 PM

Hey people, this may just be my foolishness (which is probable) but i am noticing that the pc gaming rig i recently got is not exactly living up to scratch, even though i 'think' it should be (again, im not entirely clever).

Basic Specs:
Intel i7 960 3.2ghz
6gb RAM
ati radeon hd 5970 2gb ddr5

Basically games that should be able to run on this setup with minor fps drops (such as crysis, gta IV) are not, and appear to be running slower with high settings. Again this could just be my foolishness, and this rig isnt infact great, but i believed it to be when i got it. Most games still run well (such as Just cause 2, batman arkham assylum, stalker cop)

-I have latest catalyst controll center
-I am NOT overclocking my cpu(though im guessing this will be most suggested to allow 5970 to run optimally)
-I have tried changing settings around in the catalyst control centre

Oh and I wasnt sure whether this post would be better for hardware or gaming :p 

Any help would be really appreciated to optimise what i have...
help out a technologically-challenged user :D 
Thanks :) 

More about : underperforming rig

December 17, 2010 3:13:39 PM

That rig IS infact great, you should be able to max out any current game at 2600x1560 with all the eyecandy possible and AA, 5970 is still the fastest card in the market, even though it's price/perf isn't so good.

Download and install HWmonitor and let run in the background while you play a game, post the max CPU and GPU temps here.
m
0
l
December 18, 2010 2:37:14 AM

wiinippongamer said:
That rig IS infact great, you should be able to max out any current game at 2600x1560 with all the eyecandy possible and AA, 5970 is still the fastest card in the market, even though it's price/perf isn't so good.

Download and install HWmonitor and let run in the background while you play a game, post the max CPU and GPU temps here.


Hey thanks for replying.
Temps while running GTA IV with max everything:

CPU: Cores are between 57-62 degrees celcius

GPU: GPU 1 is at about 60 deg cel and GPU 2 is at about 50 degrees celcius

So temps seem to be reasonable i think.

GTA IV graphics settings tells me i am using about 1.2g of 2g allocated memory. So it should have plenty, but im still getting real drops in fps.

If i disable catalyst ai (which i believe results in only one gpu being used), it slightly improves performance, so this may possibly mean the game's graphics have not been implemented well, although i have seen plenty of ppl max it out with high fps.

If i enable all the eye candy on crysis, well haha.... the game doesnt move (this is maxing ingame graphics and graphics in the catalyst control - simply maxing in-game graphics runs fine)...

any ideas?
m
0
l
!