Sign in with
Sign up | Sign in
Your question

Not getting gigabit speeds from my gigabit network.

Last response: in Networking
Share
July 9, 2010 4:16:31 AM

I have a windows 7 computer, and am trying to back it up to my centos server, over LAN. I have a gigabit network, am using gigabit NIC cards, cat 5e cables, and a gigabit switch.

I am using samba to share files between the two computers, but the speed decrease is experienced over FTP and http as well.

The drivers are all up to date. RDC is disabled on windows.

The speed starts off at about 80MB/s, then drops within a second to 12MB/s. And remains there, or drops to about 3MB/s.

The odd thing is that when I use iperf, I get speeds at 100MB/s. So clearly the problem isnt in the network, but in either the settings on one of the computers or the protocol.

If this ends up being in the wrong forum, hopefully someone can move it.

Thanks for your help.
July 9, 2010 5:21:41 AM

How do the machines look during the transfer? Memory / CPU / harddisk activity getting maxed out perhaps?
m
0
l
July 9, 2010 5:56:07 PM

Set up counters on your server (performance counters) to view the read/write speeds of your centos server's hard drives. You very well could be transferring more data than your server can write.
Options to speed up your server's write performance would be moving into a striping RAID which most likely will cost you additional money.

I would look at the hardware of your server next if you can validate it is not your network causing the issues.
m
0
l
Related resources
July 9, 2010 8:10:48 PM

It seems the maximum speed of the hard drive is 3MB/s. All three Hard drives in the server? which are all supposed to be 3 Gb/s?
m
0
l
July 9, 2010 9:54:35 PM

I have narrowed down the problem. It lies within my centos server. None of the drives have DMA enabled, which also explains other things about the system.
m
0
l
July 11, 2010 2:27:07 AM

For anyone whose interested, I solved the problem. When I installed centos my bios settings for sata hard drives was as IDE compatible. Switching them to IDE enhanced enabled DMA.
My drives we /dev/hdX were now /dev/sdX. The root drive mounted itself. I had the other drives mounting to /home and /disk2 so I edited /etc/fstab.

After that, I got close to 75MB/s consistently to both drives.
m
0
l
July 11, 2010 4:26:48 AM

you must have an old mobo on your server because I haven't seen an option to disable DMA in years.

Every mobo I've used in the past decade assumes it's on, but yeah, PIO mode will rape your CPU.

fyi about "[...]which are all supposed to be 3 Gb/s" If my internet was as fast as my interface(1gb), I would be happy. Sadly, most devices are not as fast as the interfaces that connect them.
m
0
l
July 12, 2010 1:11:50 PM

Thanks for the update nileshp88 on your resolution. Most people never bother updating if they resolved their issue.
m
0
l
!