Sign in with
Sign up | Sign in
Your question
Solved

570 freezing/crashing to the desktop

Last response: in Graphics & Displays
Share
December 20, 2010 7:22:28 PM

Hey crew..just got my vanilla 570 four days ago...did anyone reported freezing or crashing to the desktop while playing BFBC 2?
it happen twice in the past two days :( 
a c 388 Î Nvidia
December 20, 2010 9:24:03 PM

I'm rocking the BFBC2 on my 580 with no problems. Is your power supply up to the task? Do you have both power connectors attached to the card from your PSU? Did you install the latest drivers off the Nvidia website? Did you update the game?
m
0
l
December 20, 2010 9:50:01 PM

17seconds said:
I'm rocking the BFBC2 on my 580 with no problems. Is your power supply up to the task? Do you have both power connectors attached to the card from your PSU? Did you install the latest drivers off the Nvidia website? Did you update the game?


PSU is fine ,2 power connectors in,game is update it,...drivers installed from CD



Uploaded with ImageShack.us

when playing BFBC2 all the clocks are stock,it only freezes in old maps, Vietnam maps..no crashes so far
m
0
l
Related resources
a c 388 Î Nvidia
December 20, 2010 10:10:45 PM

You know that most reviews were only able to get the 570 up to 800 mhz without tweaking voltage? You say that you play BFBC2 at stock 732/950/1464 speeds, though. Good, because based on that screenshot I would say your clock speeds are set too high.

Another thing that jumps out is your Afterburner graph. 33c is a very low temp, by about 10c, AND yours is at 100% load on a massively overclocked card! You should be pushing 90c at least under those conditions. Even at idle, you should be around 40c. The other thing is the fan, which is at idle percentage, 40%, BUT the tachometer shows the fan at zero!

So, I would discontinue overclocking entirely, and check that your GPU fan is running before anything else. Do you have an explanation for the Afterburner irregularities, or have we identified one of the symptoms of your problem?
m
0
l
a c 388 Î Nvidia
December 20, 2010 10:22:35 PM

ortoklaz said:
man..this is soft oc ,can run haven,3D mark11 benchmarks stable,temps-that's on H2o
http://www.overclock.net/nvidia/890903-nvidia-gtx-570-5...
thanks matto

anybody ?

That explains that. Have you looked at your Nvidia Control Panel? There are some settings that need to be configured from default: Single display performance mode, VSync off, Triple Buffering off, Power management to Prefer maximum performance. Also, don't try to override AA settings for BFBC2 in the control panel. Use the ones in the game menu.
m
0
l
December 20, 2010 10:50:30 PM

17seconds said:
That explains that. Have you looked at your Nvidia Control Panel? There are some settings that need to be configured from default: Single display performance mode, VSync off, Triple Buffering off, Power management to Prefer maximum performance. Also, don't try to override AA settings for BFBC2 in the control panel. Use the ones in the game menu.


Ok thats more like it just what i was looking for, can you shed some light on the best settings performance/quality ?


Uploaded with ImageShack.us
m
0
l
a c 388 Î Nvidia
December 20, 2010 11:09:27 PM

If BFBC2 is your only problem, it would be good to see a screenshot of those settings. But, I can tell you like to mess around with the individual program settings, and have changed your default settings considerably. I would get those defaults back to Application Preference for most everything, except Single screen performance mode, Vsync off, and Triple Buffering off. When I get home later, I will check my Control Panel settings and follow up. Overall, BFBC2 has plenty of options in the game menu, and I have read that it doesn't like to have the settings overridden in the Nvidia Control Panel.
m
0
l
December 20, 2010 11:17:10 PM

ok cool..for some reason i can't make screen shot of the BFBC2 settings but AA2 visync is off AF8,my make concern is Nvidia settings global and application(BFBC2 is not listed)
m
0
l
a c 388 Î Nvidia
December 21, 2010 2:26:57 AM

I just checked and I was right. For the Global Settings I just leave everything at default, except:
VSync - Off
Multi-display/Mixed GPU acceleration - Single display performance mode (it defaults to multiple monitors for some reason)
Triple Buffering - Off
Power management - Adaptive

I think for BFBC2 it is important to keep AA and AF at Application Controlled, as well as the related AA modes at default (Off): transparency, ambient occlusion, gamma correction. Under the Program Settings, I see that BFBC2 does not allow you to make changes to Antialiasing or Ambient Occlusion. Do not try to override these.

By the way, I am running BFBC2 at 1920x1080 with 32x CSAA and 16x AF, with all other details turned up to maximum, including HBAO. I have VSync turned off. I have the clock speeds at default. The game is smooth as butter.
m
0
l

Best solution

a c 388 Î Nvidia
December 21, 2010 2:32:23 AM

ortoklaz said:
ok cool..for some reason i can't make screen shot of the BFBC2 settings but AA2 visync is off AF8,my make concern is Nvidia settings global and application(BFBC2 is not listed)

I had to use the Add button and navigate to the .exe in my C: Program Files (x86): Electronic Arts: Battlefield Bad Company 2: BFBC2.exe

Again, I would set the Global Settings back to default, with the changes I mentioned, then try to play the game. Later, you can fix the Program Settings for your individual programs, and fiddle with the BFBC2 settings as well.
Share
December 21, 2010 2:50:37 AM

Best answer selected by ortoklaz.
m
0
l
!