Sign in with
Sign up | Sign in
Your question

New power supply issues

Last response: in Components
Share
May 25, 2011 5:40:37 PM

A friend of mine recently gave me a radeon 6790 brand new he decided that he wasn't going to use, I figured then it would be my first step to upgrade a old pc of mine I had, Since this pc had a no brand 480 w power supply I'd figure I'd buy a new one for it before anything else,but this is where the problem lies.

The pc has the following:
3gb ram

Intel 805d pentium 2.66ghz
Radeon 6790 (old one was a geforce 7600GT)
Asus P5LD2 deluxe motherboard
A 320gb hard drive
And a dvd drive

The thing Is,I install the radeon with the old PSU and the computer boots perfectly fine,I can do games and everything,3gb ram is working and displaying correctly,dvd drive works,hard drive, everything is fine.

However when I plug in the PSU ( Corsair Tx 650 w v2) instead of the old PSU( 480w no known brand) the pc doesn't even get to the bios screen,motherboard beeps 1 long and 3 short,usually that points to Vga problems or ram problems with most bios but since the computer and vga and ram works fine with old psu,what could be the problem here? I can't seem to find out, I plugged in the old geforce card(7600GT) with the new PSU,same problem,tried other sticks of ram from a friend,same problem,other hard drive same problem.

What could be the issue here? Is it possible that the motherboard isn't compatible with that PSU?

It's all plugged correctly with the new psu,fans work,motherboard lights up,cpu fan works,psu,hard drive but it just doesn't get to bios screen and gives me 1 long beep and 3 short beeps.

Hope someone here could show me light on this one.

Thanks in advance

More about : power supply issues

a b ) Power supply
May 25, 2011 7:13:54 PM

You most likely got a bad unit, it can happen to anyone. RMA or return it.
!