Sign in with
Sign up | Sign in
Your question
Solved

Cannot set ACHI from IDE properly

Last response: in Systems
Share
February 24, 2011 9:20:27 PM

I did a fresh install of Windows 7 64 bit but did not install the ACHI drivers during setup.

I installed my Solid 2 State Series hard drive and updated it with the latest firmware. My hard drive I got new and it says TRIM is active when I run fsutil.exe behavior query DisableDeleteNotify and get DisableDeleteNotify=0.

I installed all the the latest drivers from the Asrock website. This is my 2nd reformat and install after editing the registry to set it to ACPI and it would hang on starting windows 7.

Core i5 2500k 3.3 ghz Motherboard
Asrock P67 Extreme 4 Memory
CORSAIR XMS3 4x2gb DDR3 1600 Ram Graphics Card
Zotac Nvidia GeForce GTX 460 768mb
Hard Drive
60 gb Solid 2 State Drive,
500gb Seagate 7200.12 hard drive
250gb Maxtor 6b250r0 with a ATA 133 to SATA 1.0 adaptor installed
Sound Card
PCI Express X-Fi Titanium Fatal1ty ...
Power Supply
Rocket Fish 700 watt power supply
Antec 600 Case
CPU cooling
Cooler Master Hyper 212 Plus OS
Windows 7 ultimate 64 bit Monitor
AL1916W 19 " Monitor 1280X1024

More about : set achi ide properly

February 24, 2011 9:53:35 PM

laserforce said:
I did a fresh install of Windows 7 64 bit but did not install the ACPI drivers during setup.

I installed my Solid 2 State Series hard drive and updated it with the latest firmware. My hard drive I got new and it says TRIM is active when I run fsutil.exe behavior query DisableDeleteNotify and get DisableDeleteNotify=0.

I installed all the the latest drivers from the Asrock website. This is my 2nd reformat and install after editing the registry to set it to ACPI and it would hang on starting windows 7.

Core i5 2500k 3.3 ghz Motherboard
Asrock P67 Extreme 4 Memory
CORSAIR XMS3 4x2gb DDR3 1600 Ram Graphics Card
Zotac Nvidia GeForce GTX 460 768mb
Hard Drive
60 gb Solid 2 State Drive,
500gb Seagate 7200.12 hard drive
250gb Maxtor 6b250r0 with a ATA 133 to SATA 1.0 adaptor installed
Sound Card
PCI Express X-Fi Titanium Fatal1ty ...
Power Supply
Rocket Fish 700 watt power supply
Antec 600 Case
CPU cooling
Cooler Master Hyper 212 Plus OS
Windows 7 ultimate 64 bit Monitor
AL1916W 19 " Monitor 1280X1024

I don't know what all the ACPI discussion is, but you didn't need to instal drivers or switch anything. The PROPER installation method would have been:

1.) With only ONE hard drive connected, set AHCI mode in BIOS first, then install Windows 7. The OS will add ITS OWN driver, MSAHCI.SYS, which you can replace with the Intel driver later if you'd like. No need for registry edits or anything else.
2.) Add any other drives when your OS is finished installing.
3.) If you want the Intel AHCI driver, you can run the Intel software update.

So basically, don't change the registry and don't change the mode in BIOS, just set AHCI from the beginning and you won't have this problem.
m
0
l
February 24, 2011 11:13:10 PM

It is completely possible to configure Windows to use the AHCI drivers so you can switch to AHCI from IDE mode. As a matter of fact, I did it. And it works perfectly. I had no issues whatsoever. I don't know what article/articles you looked at, but as I recall there were 3-5 registry entries that had to be changed, you had to make sure trim was enabled, and some other stuff that I can't recall at the moment. A simple google search will show you all the things you need to change/configure. If that doesn't work, reinstall Windows. If it's a fresh install you won't lose much, eh?
m
0
l
Related resources

Best solution

February 25, 2011 12:01:53 AM

PudgyChicken said:
It is completely possible to configure Windows to use the AHCI drivers so you can switch to AHCI from IDE mode. As a matter of fact, I did it. And it works perfectly. I had no issues whatsoever. I don't know what article/articles you looked at, but as I recall there were 3-5 registry entries that had to be changed, you had to make sure trim was enabled, and some other stuff that I can't recall at the moment. A simple google search will show you all the things you need to change/configure. If that doesn't work, reinstall Windows. If it's a fresh install you won't lose much, eh?
It sounds like he followed that type of article in a NEW installation. One should NEVER do that. What one SHOULD do in a new install is set the BIOS to AHCI first and IGNORE those articles that say to do otherwise.
Share
February 25, 2011 1:06:21 AM

Crashman said:
I don't know what all the ACPI discussion is, but you didn't need to instal drivers or switch anything. The PROPER installation method would have been:

1.) With only ONE hard drive connected, set AHCI mode in BIOS first, then install Windows 7. The OS will add ITS OWN driver, MSAHCI.SYS, which you can replace with the Intel driver later if you'd like. No need for registry edits or anything else.
2.) Add any other drives when your OS is finished installing.
3.) If you want the Intel AHCI driver, you can run the Intel software update.

So basically, don't change the registry and don't change the mode in BIOS, just set AHCI from the beginning and you won't have this problem.



I did that and the ACHI drivers installed correctly but now I cannot not boot my computer getting a blue screen when I plug in my maxtor and seagate drives
m
0
l
February 25, 2011 1:14:48 AM

laserforce said:
I did that and the ACHI drivers installed correctly but now I cannot not boot my computer getting a blue screen when I plug in my maxtor and seagate drives
But you're booting normally when you only have the one drive installed? Easy answer: One of your other drives most likely has boot files on it, and your system is trying to boot from that drive.

Easy fix: Go into BIOS and make sure that the drive you want to boot from is the first drive in the boot order :) 
m
0
l
February 26, 2011 1:03:13 AM

Best answer selected by laserforce.
m
0
l
!