Sign in with
Sign up | Sign in
Your question

Low FPS in BO with HD6870

Last response: in Graphics & Displays
Share
December 25, 2010 8:07:13 AM

Hi. I bought a new gaming rig with these specs:

ASUS Crosshair IV Formula
AMD PHENOM II X6 1090T
ASUS EAH6870
KINGSTON Hyper X 1333 MHz 4x2GB
WD Caviar Black 1TB SATA 6GB/s 64mb
XILENCE Redwing Series 700 R3

I've compared my FPS in BO with this video:

http://www.youtube.com/watch?v=z6ILdabHh9I

Thes uploader says, that hes got 43-93 fps at maximum settings.
I get only 20-60 fps with the same settings and a lower resolution (1440x900) WTF?! :o 

I've got the new catalyst for the GPU and have still have (compared to the video) low fps with basicaly the same specs.

Any help, what i need to do to get more FPS out of my GPU or sistem? I won't overclock so far, so i would like to solve this porblem with software.

More about : low fps hd6870

a b U Graphics card
December 25, 2010 9:18:33 AM

^ are you playing at the same map as benchmark?

did he actually ran a benchmark? or did he just ran fraps and saw a 93 reading?
December 25, 2010 10:58:12 AM

I was runing the benchmark on the same mission. If he did the benchmark I don't know.
Related resources
a b U Graphics card
December 25, 2010 10:59:31 AM

Have you downloaded all the patches for BO?
December 25, 2010 2:07:04 PM

Tamz_msc said:
Have you downloaded all the patches for BO?


I already updated everything. I think its a problem with the software and driver, but I'm not sure. I've this problem with other games too (Dirt 2, F1 2010). I need help with the drivers. I've git the new catalyst and amd Overdrive already. Do i need to improve the performance the other drivers, like for mobo or CPU?
!