Sign in with
Sign up | Sign in
Your question

HD6870 graphic glitches,surprisingly only happens in DX9 games!

Last response: in Graphics & Displays
Share
December 26, 2010 11:47:58 PM

I encounter graphic glitches like what happened to overclocked graphic card, and sometimes it crashes the game which I have to forcibly close via task manager. the glitches are very random and minimal, it isnt always happened in games and surprisingly it only happens in older DX9 games like Warcraft III and PS2 emulator. The glitches never happen in newer games though. The glitches are not present when i tested by removing the discreet graphic card 6870 and run on the build in 785G graphics. Which leads to the possibility of a faulty graphic chip on my HD6870 :( 

My system specs is as follow: Phenom II X2 unlocked to X3 @ 3.3GHz, Asus 785G mobo, 4GB ddr3 RAM, Sapphire 6870 graphics, Win 7 64bit and Catalyst 10.12

My question is, does any hd6870 owners facing the same problem as mine here?
a c 172 U Graphics card
December 27, 2010 3:07:04 AM

unlikely faulty graphic card. if it fails on older games then its just an incompatability with older stuff and also the AMD drivers are not very refined for that card. write a complaint to AMD so they can try to correct the problem with the next driver release.
m
0
l
December 27, 2010 3:45:54 AM

why is it only happen in DX9 games? I run a stress test via Furmark and there isnt any problem at all.
m
0
l
Related resources
a b U Graphics card
December 27, 2010 7:45:08 AM

When you say "DX9 games", how old are we talking here? 2001 old, or 2009 old?

Could be a driver problem; I'm still on 10.5, as they are stable and I see no reason to upgrade.
m
0
l
December 27, 2010 8:09:05 AM

Ok here are some of the DX9 games which i tested; Quake 4, Warcraft III(should be 8.1 i think), Doom3, PS2 Emulator, basically most games as old as 2002 to 2007. And one more, NBA 2010 as well.
m
0
l
December 27, 2010 6:15:02 PM

what is your power supply. also, are you *sure* your unlocked x3 is totally stable. run prime 95 for an extended period of time while running your dx10 (to verify dx10 crashes/doesn' crash) games
m
0
l
December 27, 2010 10:59:56 PM

My unlocked phenom third core is able to run 24++ hours of prime95 (3 threads). I ve been running this unlocked Phenom for over a year already and it was just recently I upgraded my graphics to a Sapphire 6870. And as I said previously, there are no problem if i were to run newer games/benchmark, it only happens in older games, esp DX9/DX8.1(Warcraft III).

I just tested running orthos (3threads) while running 3dmark vantage. after it finished, I tested Furmark for 5hours++ (with 3 orthos running too). All gives positive result without any graphic glitches or crashes.


by the way, my PSU is a Seasonic S12 II 520W.

*I tested in Windows XP, the problem just got worst. In Warcraft III, graphic glitches is so terrible that I cant even play a game properly, and in the menu there, the screen flickers.
m
0
l
a c 172 U Graphics card
December 28, 2010 4:37:40 AM

sounds like a driver compatability issue, as new games run fine. Maybe get someone else with the same card and driver to try warcraft 3 and see if it has the same problem.
m
0
l
a b U Graphics card
December 28, 2010 6:52:26 AM

edwuave said:
Ok here are some of the DX9 games which i tested; Quake 4, Warcraft III(should be 8.1 i think), Doom3, PS2 Emulator, basically most games as old as 2002 to 2007. And one more, NBA 2010 as well.


Heres the problem: None of those even use direct X (except MAYBE warcraft III): Quake is OpenGL, as is doom 3. PCSX2 is still needing a LOT of work, so I can't take any talk of graphical glitches on that front seriously.

Could be more issues with ATI/AMD OpenGL drivers? Haven't toyed around with OpenGL compatability since the late 10.x series drivers started to mess up OGL again...
m
0
l
December 30, 2010 2:19:06 AM

iam2thecrowe said:
sounds like a driver compatability issue, as new games run fine. Maybe get someone else with the same card and driver to try warcraft 3 and see if it has the same problem.


Tested more games, Elder of scrolls Oblivion run fine full in game, but the menu was having serious graphic glitches :o  , this is weird, why it happens in menu but not in the game?
m
0
l
December 30, 2010 8:30:59 PM

Hey i'm having a similar issue on windows 7 with an intel graphic card.
I can run WC3 in normal mode with HUGE lag spikes, while running it in Opengl mode stops the lag but causes enormous graphic bugs but still playable.
Is there a way to solve this problem?
m
0
l
!