Solved

5770 and WOW

I've been playing WOW for the past couple days with minimal lag, but today after updating drivers on my 5770, the game won't even play smoothly on low settings at 1080p. I was running the game fine at ultra 1080 without a hitch the last couple days, but just today its terrible. Any time i turn my character it hangs or pan the camera.

I am running an Asus EAH5770 with the current drivers installed.

I have even reinstalled WOW , but the graphics lag is still there.

Anyone know how to fix this?
7 answers Last reply Best Answer
More about 5770
  1. Best answer
    Are you running CCC? if so go in there and set the settings that let you check "Let application decide" with the box checked on.

    Also did you update the drivers in the appropriate manner? meaning you uninstalled all ati components,rebooted,unistalled in device manager,rebooted, ran driver sweeper for stragglers,rebooted then installed new ones?

    Another thing to consider as maybe it is just a coincidence that your performance dropped when you updated, are your temps normal? fan activity normal?

    this issue can be more general than you think upon further inspection, check the stuff out mentioned above and see if you draw up any conclusions, if not we can go further down the list, thanks.
  2. i'd give it time, WoW is downloading a patch in the background so if your connection is slow that might be hurting you , also if the HDD is slow , sata 1.0 , or IDE you might also have a bottleneck there getting data off of and onto the hdd

    one way to chweck this is to load up a game other than WoW and see if you are having troubles.

    otherwise i'd suggest completely uninstallign the drivers to your graphics card, running drive sweeper in safe mode then rebooting and installing

    then when you turn on WoW try it without dx11 mode then with dx11 mode to see which is better (turn dx11 mode on by typing /console d3d11 )
  3. When you updated the drivers did WOW do an autodetect of your system again ?? --- with the 57xx series cards some of the autodetects for game mistake the ATI 57xx series for an older Nvidia FX57xx series card and turn off most of the shaders and set other things incorrectly thinking it is an Nvidia card --- If this is the case go in and manually adjust the settings back to the correct ones using the in game options.
  4. DOH i think i figured out your problem >_< it happens with WoW and ASUS card, happened to mine

    disable Gamer OSD software it won't hurt most games, but WoW does not like it... wow why did i not notice this, took me a few days to figure out why my ASUS TOP gts 450 wouldn't work properly

    *add*

    i should add to explain, as the problem happens when you turn thats the giveaway, that is what i was having issues with origionally researched the issue for gts 450 in general btu then that got me nowhere, so i researched my card and asus cards in general and gamer osd was a known issue with WoW

    hope that fixes it
  5. g00fysmiley said:
    DOH i think i figured out your problem >_< it happens with WoW and ASUS card, happened to mine

    disable Gamer OSD software it won't hurt most games, but WoW does not like it... wow why did i not notice this, took me a few days to figure out why my ASUS TOP gts 450 wouldn't work properly

    *add*

    i should add to explain, as the problem happens when you turn thats the giveaway, that is what i was having issues with origionally researched the issue for gts 450 in general btu then that got me nowhere, so i researched my card and asus cards in general and gamer osd was a known issue with WoW

    hope that fixes it



    Nope thats not it, i totally dished the asus bundled software the second time i did a clean sweep. I seems the only way I can get it to work is by uninstalling the drivers in device manager, then restarting, letting windows download the drivers, restart, and then it work fine until i restart my computer again. So any time i restart it breaks the driver.
  6. You just updated to the newst drivers for the 5770 right?
    Just roll back the drivers or download the previous older version.
    Probably just error in the code that happens to affect WoW.I'm sure if you look around your not the only one that has this problem,if it is driver related then you will have to wait until their next driver update that will patch it,otherwise just get the old driver.

    EDIT:If windows is downloading the drivers for you, turn off the auto-update so it doesn't patch you to the newst driver.
  7. Best answer selected by Godlover1133.
Ask a new question

Read More

Graphics Cards Drivers Lag World Of Warcraft Graphics