Color Power HD 6850 HELP!

hey guys I recently build a new gaming rig I have
I7 950
Asus Rampage III GENE
3 x 2 GB Corsair XMS3 1600 Mhz
and a Color Power HD 6850

from what I am told I should be able to max out about every game I play at 1920 x 1080 however this is nowhere near the case in World Of Warcraft I have matched my friends settings he is using a HD 5850 while I am at 20 FPS hes at 80+ FPS I know that the 5850 has more raw power but not 4x the power of the 6850

I have installed the latest ATI drivers I have tried overclocking but I get the same results just higher temperatures on the card

any ideas?

EDIT : also I forgot to mention when i first built this rig I was using an old HDD with windows XP on it and with 3 Gb of ram I was getting much more out of this card
14 answers Last reply
More about color power 6850 help
  1. 5850 is faster then the 6850 if i recall correctly. And world of warcraft isnt a game that you want to compare gpu's from.

    If you are sure you dont get enough bang from ur 6850 though, check if your graphics card gets enough power from your psu and that its installed correctly.
  2. Even a HD5850 cannot max out every game at 1680x1050, let alone 1920x1080.

    Remember, XP is not DX11, so you were not running the game in DX11, but NOW you are likely running DX11 if your running Vista or 7.
  3. Did you do a clean instal after you put the 6850 in? if you didn't then it's most likely a driver conflict.

    Uninstall your current drivers then download and run driver sweeper under safe mode to remove all the leftover files, then reboot and install the newest drivers.

    Also download the free version of 3dmark11 and post your score here, just to see if your card is performing as it should and it's not a problem with the game
  4. I did a clean install of Windows 7 Ultimate 64-bit on a new HDD so I am running Dx11 and my point with the World of warcraft thing was my friend who has the HD 5850 is getting 4x the frames i am
  5. And is your friend running the DX11 version aswell?
  6. wiinippongamer said:
    And is your friend running the DX11 version aswell?


    of WOW yes he has

    Windows 7 ultimate 64-bit
    I7 930 over clocked to 3.7 GHz
    6Gb of ram (i dont know what type) 1600 Mhz
    and a Hd 5850

    so he really doesn't out spec me
  7. Did you reformatted right befor putting the 6850 in or before that? What about other games/ benchmarks, do they run slow too?

    Download and install HWmonitor and let it run in the background while you play a game for a while, post max CPU and GPU temps here.

    Try reinstalling the game and also run 3Dmark11 or any other synthetic benchmark to compare your results with similar systems, it could just be a problem of the game with this specific driver release and OS, that if the temps aren't too high.
  8. wiinippongamer said:
    Did you reformatted right befor putting the 6850 in or before that? What about other games/ benchmarks, do they run slow too?

    Download and install HWmonitor and let it run in the background while you play a game for a while, post max CPU and GPU temps here.

    Try reinstalling the game and also run 3Dmark11 or any other synthetic benchmark to compare your results with similar systems, it could just be a problem of the game with this specific driver release and OS, that if the temps aren't too high.


    when i was on XP i was using a different Hard Drive it was not a fresh install

    and I have checked with 2 other games and i just tried 3dmark 11 Basic

    the other two games were Killing floor when inside a building i get 30- 40 frames when im outside 10 - 30 my friend hasn't checked his fps but he has no problem and no lag the entire time

    and Counter Strkie Source while i was on the Hard drive with xp using this video card I was gettin 300 fps (the game is capped at that) now on windows 7 I am geting 44

    the 3d Mark basic I cant post benchmark scores but I never got over 30 fps on 720 in the grapic tests al I got the following error

    Workload work failed with error message: window_focus_lost: Keyboard focus lost
  9. Well either the install was messed up somehow like what wiinippongamer said or 3DMark11 is right and your video card wasn't right from the start. Buy not running it in DX11 mode with winXP and only in DX9. Just RMA with the brand and get a new one. Here is a bench of wow with both 5850 and 6850 cards at different resolutions to show that your only supposed to be around 12% difference with the 5850: http://www.techpowerup.com/reviews/ATI/Radeon_HD_6850_CrossFire/18.html
  10. Download and install HWmonitor and let it run in the background while you play a game for a while, post max CPU and GPU temps here. It sounds like it's very likely an overheating problem, the cpu heatsink may have gone loose or something.
  11. wiinippongamer said:
    Download and install HWmonitor and let it run in the background while you play a game for a while, post max CPU and GPU temps here. It sounds like it's very likely an overheating problem, the cpu heatsink may have gone loose or something.


    I was playing killing floor and here is what i got

    my i7 cores range from 30-38 right now during the game the highest temp was 45 Celsius the range was 38-45

    my video card is currently at 36 Celsius the highest was 69 Celsius
  12. When you installed your card and drivers, did you go to the 3D settings in the CCC and adjust things? You may find you have AA over writing the ingame settings. You may have supersampling AA on which is a FPS killer. You might have texture filtering and other settings different from your friends.

    Make sure your CCC 3D settings are the same as your friends.
  13. bystander said:
    When you installed your card and drivers, did you go to the 3D settings in the CCC and adjust things? You may find you have AA over writing the ingame settings. You may have supersampling AA on which is a FPS killer. You might have texture filtering and other settings different from your friends.

    Make sure your CCC 3D settings are the same as your friends.


    that helped a little but im still only getting 20- 40 FPS
  14. It's the card then, RMA or return it.
Ask a new question

Read More

Radeon Power HD Graphics