Sign in with
Sign up | Sign in
Your question
Closed

Crysis on GTX570 ?~freezing

Last response: in Graphics & Displays
Share
December 29, 2010 7:15:31 PM

Hey crew I have some issues playing freshly installed Crysis on steam ,some times the game will freeze with audio running in the background
I'm sure it have something to do with settings in Nvidia control or game settings ,when the game starts sometime it will go to window mode with the some message about D10/Nvidia control stop responding ,should i have Vsinc on or off in the game?
here are some settings;


Uploaded with ImageShack.us


Uploaded with ImageShack.us


Uploaded with ImageShack.us
the settings in the game are all high AA8 ,Vsinc off

More about : crysis gtx570 freezing

a b Î Nvidia
December 29, 2010 7:55:17 PM

VSync shouldn't have anything to do with it honestly. You may want to make sure you have the latest updates for DirectX installed. You can download the DirectX installer directly from Microsoft's website.

It's also a good idea to make sure you're using the absolute latest nVidia drivers (which I think are from November). Though I presume if you're using a GTX 570 you have the latest drivers. Did you uninstall and then reinstall the nVidia drivers when you installed the new GTX 570?

As far as Crysis opening in Windowed mode.. that's normal I think. If I ever tab out of that game it re-opens in a window and won't go full screen until I re-launch the game. It's stupid like that. Often times I had to go into settings and reselect Full Screen within the game to make it open in full screen again.
Score
0
December 29, 2010 8:12:26 PM

tested your hardware?
Score
0
Related resources
a b Î Nvidia
December 29, 2010 8:16:01 PM

ortoklaz, your member config says this is your rig:

Quote:
Gigabyte MA785GM-US2H,AMD Phenom IIx4 940 @ 3.7ghz,custom single loop H20
,4GB Corsair CM2X2048-6400C5,2xWD Black 500GB,GTX570(972/1944/2099)
Corsair HX850W,Lite-On 24X,Win 7X64bit,TT Spedo


Both the CPU and video card are OverClocked. Either of those could also cause instability or game crashes. You should test both with Prime95 (for CPU) and Furmark or something similar for the video card.
Score
0
December 29, 2010 8:37:55 PM

@jerreece thank you for your quick respond ,every new game I play i start all at default
settings ,anyway i turned on Vsinc in game settings restart the game from beginning and so far no problem
I will report back if something come up thanks
Score
0
a b Î Nvidia
December 29, 2010 9:01:05 PM

Interesting. Vsync really only changes things by keeping your video card's output equal to what the monitor can display. For most monitors this means you are capped @ 60 Frames per Second. This helps by giving you a more consistant/smooth image (can fix issues of image tearing). It really shouldn't have much of any affect on system stability.

My guess is, if there is really a problem (be it a driver, or hardware instability) it'll pop up again.
Score
0
December 29, 2010 9:29:47 PM

jerreece said:
Interesting. Vsync really only changes things by keeping your video card's output equal to what the monitor can display. For most monitors this means you are capped @ 60 Frames per Second. This helps by giving you a more consistant/smooth image (can fix issues of image tearing). It really shouldn't have much of any affect on system stability.

My guess is, if there is really a problem (be it a driver, or hardware instability) it'll pop up again.


Yep it's freezing again ,last time i could't even load the game;


Uploaded with ImageShack.us
had to start all over from the beginning,i know the game is DX10 but when i download the driver from cd
i think i did the DX install to ,should i install Direct X again? and which link ?
Score
0

Best solution

a b Î Nvidia
December 29, 2010 9:51:36 PM

I'm going to say this is a video card OverClock problem. It's the nVidia Control Panel that's crashing. Which means it's a software/driver that's crashing. Because your video card is overclocked, this can cause a driver crash.

So, I would recommend you set the video card back to Default / Stock Clock settings entirely and reboot the system. Then try playing again. Honestly with your GTX 570 you should master any game you want without having to OC anyhow.

Try setting things to default settings and try again. See if this solves the issue. If it does NOT fix the problem, I'd recommend uninstalling ALL your nVidia drivers and running Driver Sweeper to remove them. Then reinstall all the drivers again.
Share
December 30, 2010 6:27:44 AM

This game is something else..but i should't complain i guess ,talk to some guys on OCN;

Quote:
Originally Posted by rpgman1
"I can only pull 28 FPS on 1920x1080 with 2x AA for my GTX 275 (1792MB) and 4.2GHz i7 920 C0 on Medium settings. Definitely need a new video card."

any way ,(default clocks)
This is weird (all high settings) at AAx4 it gets choppy , at AAx8 little better but AA8Q is like a sweet spot with 35~65FPS (average 45 FPS) ,playing for two hours
at AAx16Q stable but AAx4 it fills like it's about to crash

Score
0
December 30, 2010 1:51:46 PM

Best answer selected by ortoklaz.
Score
0
a c 171 Î Nvidia
December 30, 2010 3:11:06 PM

This topic has been closed by Mousemonkey
Score
0
!