MSI 870A-G54 usb problem

So here's the problem
A few weeks ago my motherboard died/defected & I sent it to get replaced.

Today i got it back brand new put everything all together again turned it on it was running until this problem occured
Whenever there's a usb on the back where the mobo is when i turned on the comp i get a "Initializing USB Controller"
and just freezes there I can't go to bios or F11 at all it just froze. So i took out all the usb on the back and turned it on and it worked fine windows was able to run and i had to plug all the usb on the back again and it works but the problem keeps happening everytime I have a USB on the back when i turn it on.


anyone know any solutions for this?
2 answers Last reply
More about 870a problem
  1. Try going into BIOS and check the boot order... remove USB if possible or at least put it as last option. Failing that check to see if the motherboard has some new BIOS updates or driver updates. If all this fails then set BIOS to defaults or optimum settings>save>reboot BINGO! hopefully....

    If still not fixed try reset CMOS for old time sake :D
  2. does it do this freezing on different usb-equipments (stick,hdd....etc) or just on one particular,
    did u try on different slots at a time ( all of them)?
    tried two at once?
    if yes i would recommend you bring it back to your suplier after you do what "kevlarkev" proposes!
    Greez
    Gab
Ask a new question

Read More

MSI-Microstar Motherboards USB