Sign in with
Sign up | Sign in
Your question

Can't get into BIOS on my laptop

Last response: in Motherboards
Share
February 4, 2012 12:35:12 PM

It's super strange, I just can't enter the bios on my Toshiba Satellite C660.
I've tried pressing F1-F12/INS/DEL it all didn't work.
I'm trying to boot from a cd and I can't do it without entering the BIOS.

Your help will be very much appriciated!

More about : bios laptop

a b D Laptop
a c 328 V Motherboard
February 4, 2012 12:58:42 PM

Remove any screws holding the BIOS battery door in place. Then identify the battery, (it is generally a small lithium "watch" battery), and remove it taking care not to damage any surrounding circuitry. Let the computer rest for a minute or two to discharge any remaining power, and replace the battery.

Read more: How to Reset the BIOS on a Laptop | eHow.com http://www.ehow.com/how_4740583_reset-bios-laptop.html#...


http://www.ehow.com/how_4740583_reset-bios-laptop.html
February 4, 2012 1:14:06 PM

is there any way to do that without opening the laptop up?
im really concerned about doing that.
Related resources
a b D Laptop
a b V Motherboard
February 4, 2012 2:48:25 PM

"f2"
February 4, 2012 5:09:40 PM

it doesn't work...
I think I have enabled the "fast boot" thing the other guy enabled, and now it skips the bios.
what can I do? I'm way to afraid to open the laptop up...
February 4, 2012 5:21:37 PM

OK, so I solved the problem with holding the F2 key BEFORE hitting the power button.
thanks everyone :) 
!