Sign in with
Sign up | Sign in
Your question
Closed

Asus P8Z68-V/Gen3 USB 3.0 Not working

Last response: in Motherboards
Share
February 4, 2012 1:19:07 PM

Just put together a new PC last night, only to find out that during Windows 7 installation the keyboard and mouse did not work.

They work in the BIOS screen, however. I had them plugged in through the back USB 3.0 ports, and I had suspected that was the problem. I had to use my front ports as USB 2.0 and they worked fine in the installation.

I installed the mobo drivers once windows installed and the USB 3.0 drivers worked... until I updated windows 7. Now they are unresponsive like before: works in BIOS, not in windows.

Numerous google searches have left me hours into this with no solution. Any help would be greatly (GREATLY) appreciated!

Thanks.
a b Ĉ ASUS
a b $ Windows 7
a c 180 V Motherboard
February 4, 2012 3:19:27 PM

Did you try to reinstall the usb 3.0 drivers? Somethimes drivers can be knocked out with an upgrade or an install of another hardware part. So enen though you had installed the drivers and it was working try to reinstall them again.
Score
0
February 4, 2012 9:46:29 PM

I have tried reinstalling them; both from the manufacturer CD and downloaded from the website.

Somehow, I have miraculously "solved" my problem, at least for now. I did everything I did last night pre-reformat, but this time the USB 3.0 worked.

Thanks for the response!
Score
0
Related resources

Best solution

February 4, 2012 10:17:58 PM

if it happens again you need the etron usb 3.0 controller drivers
try these
http://gigabyte-ga-990fxa-ud3-rev-1-1-etron-usb-3-0.dri...
i know it says gigabyte but they also use the etron controller
Share
February 9, 2012 4:58:03 AM

Best answer selected by emyang.
Score
0
a b Ĉ ASUS
a b $ Windows 7
a c 328 V Motherboard
February 9, 2012 6:20:09 AM

This topic has been closed by Nikorr
Score
0
!