Sign in with
Sign up | Sign in
Your question
Closed

Hdmi audio out not working

Last response: in Graphics & Displays
Share
December 30, 2010 11:46:19 PM

Hello all. I got a a Gateway p-7815u for xmas, and the hdmi audio out isnt working when I plug it into my receiver. The video works fine on my tv, but the audio wont play. I have the hdmi selected as default device, and the computer shows music playing in the volume level, but nothing can be heard.

My old computer, the hdmi out works fine and audio can be heard. I have also had this problem with a friends p-7815, so it must be our computers. How do I fix this? Thanks!

Windows 7 x64 is being used as the os.

More about : hdmi audio working

December 30, 2010 11:52:51 PM

I have the same laptop as you got it from tigerdirect. I called tigerdirect and gateway about it and they told me that sound didnt go threw it but it does reinstall the drivers get them from gateway.com
Score
0
December 31, 2010 8:54:13 AM

Cia, what driver does your hdmi say it is using? Nvidia 1.1.9.0 is what is says for mine, even after downloading and installing the 2 audio drivers listed on gateways website. I also got mine from tigerdirect.
Score
0
Related resources
December 31, 2010 3:46:20 PM

I have no idea if this is even relevant but I had a desktop computer with integrated graphics and to get HDMI audio to work I had to change the video option in the BIOS from VGA/DVI to VGA/HDMI. Check your bios and see if there are any settings for your video card in there and make sure they are set to HDMI. I was able to get video, just not audio until I made this small change.
Score
0
December 31, 2010 5:34:32 PM

The bios on these gateways is locked down lol i don't like it.
Score
0
December 31, 2010 7:53:34 PM

yea, the bios is absurd. There are basically no options to do anything like that. Also, i have the realtek drivers downloaded, but cant install them. Each time I remove the driver, it must reboot, and before I can install the new realtek driver, Windows auto installs the default Microsoft HD audio device driver. So then I try the process again, and Windows 7 just keeps installing that driver on boot up. This is getting really annoying.
Score
0
December 31, 2010 8:00:50 PM

ya can install the driver anyways for the realtek and should automatically find the hardware for it in 7 without having to uninstall the old driver or go to device manager after install than click on the high def audio and click properties then click update driver then choose browse my computer for software and install from there :) 
Score
0
December 31, 2010 8:12:19 PM

Well, I have tried that but the list from "have disk" shows like 20 different "Realtek High Definition Audio". I have tried a few of them and upon reboot the device cannot start. I selected the folder where the drivers downloaded to.
Score
0
December 31, 2010 8:19:01 PM

Most laptops have their BIOS locked down. I didn't think that would help but I thought I would mention it.
Score
0
December 31, 2010 8:20:28 PM

are ya using the realtek 2.55 audio drivers?
Score
0
a b Î Nvidia
December 31, 2010 8:49:53 PM

Might be a stupid question but...
When you right click the speaker(bottom right desktop) go to "Playback Devices" make sure it's set to play thru the "Digital Output" not the speakers.You can also set both the speakers and the digital output to default it does't matter.

Hope that helps...
Score
0
December 31, 2010 10:28:07 PM

^-oh yea and left click somewhere inside there and tick show disabled devices and see if one of those will work also
Score
0
December 31, 2010 11:44:16 PM

Well, I have tried all of those. I have the hdmi set as default, and it shows everything as working. I even checked the nvidia control panel to make sure "HDTV audio enabled". It shows as audio is coming out, (like the volume bar shows green with level fluctuations).

I used my other lappy just to make sure that my receiver is set properly to detect all signals, and this is the only lappy where the hdmi audio out doesnt work. Im getting really confused as to why it isnt.
Score
0
December 22, 2011 4:57:14 PM

I stumbled upon this solution. Hope it works for all of you.
Open device manager (control panel-device manager).
Expand "sound, video and game controllers".
Right click the "NVIDIA High definition Audio".
"Enable"

Ok.

Open your volume control settings again and the device you are connecting HDMI to will now be visible. Activate that and bingo ure good to go.

UrbanImage
Score
0
!