Sign in with
Sign up | Sign in
Your question

Sharing internet through USB Cable Modem

Last response: in Wireless Networking
Share
Anonymous
October 13, 2010 12:34:58 PM

Hello,
I have Motorola SURFboard SB5101 - Cable Modem connected with USB cabl' to my PC for internet access. I can't access internet using modem's LAN port (maybe because that option is not given by internet provider).
I have connected Linksys Wireless-G Home Router to PC's network port to be able to connect my laptop to the PC. I would also like to browse internet with laptop by sharing PC's internet connection. On PC's networking window two networks are visible. One is public with modem in it even do the modem is connected to PC with USB cable. The second is wireless work network between PC and laptop.
I can't realize internet sharing and can't browse internet on my laptop. Can somebody help me with necessary configuration?
Anonymous
October 13, 2010 12:44:21 PM

Have a look at Internet Connection Sharing (ICS) in Windows Help. Basically you connect computer A to the modem and connect computer B to computer A by ethernet cable.

As ICS is not a great way to work, instead I would see if you can connect the modem by ethernet cable to the wireless router and connect the two computers to the router by wireless or ethernet cable.
Anonymous
October 13, 2010 1:09:27 PM

Yes, but how do I do that. As I said, I've tried once to connect modem to PC via ethernet cable, but I couldn't connect to the provider's server. That's way I think internet provider disabled that option somehow.
And about ICS, ther's no Sharing option on public network connected to modem.

Thnx
Related resources
Anonymous
October 13, 2010 1:14:26 PM

Did you restart the modem and router together so they handshake ?

Download the manual for the router -- if the router is designed to connect to a modem it should work.

"And about ICS, ther's no Sharing option on public network connected to modem."
Sorry, don't understand that statement.
October 14, 2010 3:18:32 AM

Yes when you connect modem using USB, the lan port of the modem gets disabled.
Once you connect LAN port to comptuer, you have to make sure USB cable is unplugged and you have to restart the modem.
Also note, some modems have a backup battery that must be unplugged as well to do a complete restart.
You can check if any lights are still lit up even after the power is unplugged.

Regarding ICS, I believe its possible to set that up.
<modem> ---- < Desktop's USB port > ----- < Desktop's LAN port > ------ < Linksys Router's LAN port > ~~~~~~~~ < Laptop's Wireless connection >
[Linksys Router's DHCP should be disabled in this setup and manually assign laptop an IP]
We can try this out as the last resort.

Let up know if you were able to get the LAN port working on the modem.
By the way what are the operating systems on PC and laptop?
Anonymous
October 14, 2010 8:41:58 PM

I couldn't get modem to connect by LAN port. It only works with USB cable.

I'm still trying to get ICS to work. I've connected everything as you suggested, PC and laptop are connected by Linksys Router which is connected to PC's LAN port. PC and laptop can see each other, but I can't browse the net on laptop. Internet sharing is enabled on public network connected to the modem. Something is definitely not configured right.

By the way, laptop uses WinProXP, and PC Win7.
October 15, 2010 2:50:15 PM

If you can't get the LAN port to work, contact the service provider.

Just connect the fixed modem to your router's WAN port and connect the comptuers to the router.
October 15, 2010 8:39:49 PM

We'll have to disable the DHCP Server on the router.
While your desktop is still connected to router's LAN port, open a browser and go to router's web interface.
Ex. address would be 192.168.0.1 or 192.168.1.1
  • How to access router page
  • Disable DHCP Server on router
  • Change your router's ip to 192.168.0.100, so that you can access it in case you need to change any other settings.

    On the PC [Windows 7]
    Start --> Control Panel ---> Network and Internet --- > Network and sharing Center.

    On the left hand side menu select "Change Adapter Settings", right click on your USB connection to the modem and click "Properties".
    Select the tab "Sharing" and check mark "Allow other network users to connect through this computer's internet connection".
    below that if there is a drop down menu select your Local Area connection there. Click OK to apply the settings and close the window.

    It may sometimes as you to restart the computer, go ahead and do that. Or it may say the settings will take effect on the next reconnect. So just go ahead and restart the computer.

    On the laptop
    [I'm assuming your connecting wired to the router. If its wireless, apply these settings to Wireless network connection.]
  • Assigning a Static IP Address on a Wired Computer
    Set the LAN IP address to 192.168.0.2, Subnet Mask to 255.255.255.0, Default Gateway to 192.168.0.1
    Primary DNS to 192.168.0.1

    You should be set by now.

    You could do this or like "hang-the-9" said just get the ISP to fix/replace the modem.
    September 21, 2011 4:04:37 PM

    Hi im yousuf from bangladesh many many & many thanks for information above , i follow ur steps and its really worked , ur great , keep it up ur good work, cheears .Thanks again
    !