Sign in with
Sign up | Sign in
Your question
Solved

Powercolor 5770 Flickering and occasional BSODS

Tags:
  • Graphics Cards
  • PowerColor
  • ATI
  • Graphics
Last response: in Graphics & Displays
Share
January 2, 2011 6:50:30 PM

I have the above video card since end of May. Recently, I noticed flickering of the screen when starting to play movies. On another Windows 7 profile I noticed the same except even when viewing some pictures and occasional flickering on it's own.

I seen that the ATI Radeon has these issues with the 5770 but there is no mention of this Powercolor brand. The good thing is the ATI has a lifetime warranty but the band thing is the Powercooler only a two year warranty.

I wonder if this maybe could be a driver issue as well since I have been installing ATI drivers, NOT Powercooler drivers. If so, is there a way to remove all the video drivers completely and install just the Powercolor?

I am running Windows 7 64 but with a 700 watt Coolermaster PSU.

More about : powercolor 5770 flickering occasional bsods

January 2, 2011 8:47:35 PM

If your refresh rate is set low it will seem like the screen is flickering.

To uninstall ATI drivers, download Drivesweeper and run it in safe mode.
Then you can put in your Powercolor disk after the system reboots into normal mode.
m
0
l
January 18, 2011 7:48:50 AM

I have one of these as well, purchased in the last week, initially it was fine but after dropping on the latest drivers I started noticing a strange flicker. After logging in, as the screen fades to black, the entire screen wobbles left to right, then goes blank and then shows the desktop. The same thing happens if I go into CCC and adjust the gamma settings, everytime I modify the gamma up or down the entire screen shifts left and right very quickly. I'm yet to try the powercolor drivers but I will and cross my fingers.
m
0
l
Related resources

Best solution

January 18, 2011 9:17:55 AM

Jayman007 said:
I have one of these as well, purchased in the last week, initially it was fine but after dropping on the latest drivers I started noticing a strange flicker. After logging in, as the screen fades to black, the entire screen wobbles left to right, then goes blank and then shows the desktop. The same thing happens if I go into CCC and adjust the gamma settings, everytime I modify the gamma up or down the entire screen shifts left and right very quickly. I'm yet to try the powercolor drivers but I will and cross my fingers.



Didn't touch the drivers nothing, changed my cable from a HDMI - to - DVI(HDMI from the video card to DVI into the monitor) works a treat, no more flickering. Might leave it like this until new drivers are posted from ATI.
Share
January 28, 2011 3:09:37 AM

Looks like the HDMI port and/or drivers is indeed the culprit. I no longer use HDMI and the problem has gone away after changing my refresh rate to back 60 or 75.

BTW, Powercolor only has a 2 year warranty.
m
0
l
January 28, 2011 3:12:44 AM

Problem is partly fixed. HDMI does have an affect.
m
0
l
January 31, 2011 4:41:45 AM

Just an update. The problem didnt go away completely. I still get video tearing! :( 
m
0
l
!